summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2021-04-17 21:09:44 +0200
committerPacho Ramos <pacho@gentoo.org>2021-04-17 22:08:19 +0200
commit4664467787ca26dc8ec56918e9619bfa7681b954 (patch)
tree473a840d4ec222951d652582d50c9b504ec30da3
parentapp-text/atril: Support newer python versions (diff)
downloadgentoo-46644677.tar.gz
gentoo-46644677.tar.bz2
gentoo-46644677.zip
media-sound/pulseaudio-modules-bt: Port to cmake.utils
Closes: https://bugs.gentoo.org/783408 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
-rw-r--r--media-sound/pulseaudio-modules-bt/pulseaudio-modules-bt-1.4.ebuild24
1 files changed, 12 insertions, 12 deletions
diff --git a/media-sound/pulseaudio-modules-bt/pulseaudio-modules-bt-1.4.ebuild b/media-sound/pulseaudio-modules-bt/pulseaudio-modules-bt-1.4.ebuild
index 56a66ff8e9e3..9139708288d2 100644
--- a/media-sound/pulseaudio-modules-bt/pulseaudio-modules-bt-1.4.ebuild
+++ b/media-sound/pulseaudio-modules-bt/pulseaudio-modules-bt-1.4.ebuild
@@ -1,8 +1,8 @@
-# Copyright 2019-2020 Gentoo Authors
+# Copyright 2019-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake-utils readme.gentoo-r1
+inherit cmake readme.gentoo-r1
DESCRIPTION="PulseAudio modules for LDAC, aptX, aptX HD, and AAC for Bluetooth"
HOMEPAGE="https://github.com/EHfive/pulseaudio-modules-bt"
@@ -51,6 +51,14 @@ load-module module-bluetooth-discover
.endif
"
+src_prepare() {
+ cmake_src_prepare
+
+ # pulseaudio headers needed to build
+ rmdir pa/ || die
+ ln -s ../pulseaudio-${PULSE_VER}/ pa || die
+}
+
src_configure() {
local mycmakeargs=(
-DCODEC_AAC_FDK=$(usex fdk "ON" "OFF")
@@ -60,19 +68,11 @@ src_configure() {
-DNATIVE_HEADSET=$(usex native-headset "ON" "OFF")
-DOFONO_HEADSET=$(usex ofono-headset "ON" "OFF")
)
- cmake-utils_src_configure
-}
-
-src_prepare() {
- cmake-utils_src_prepare
-
- # pulseaudio headers needed to build
- rmdir pa/ || die
- ln -s ../pulseaudio-${PULSE_VER}/ pa || die
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
readme.gentoo_create_doc
}