summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-13 22:04:04 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-13 22:31:10 +0200
commit466c1bd3c104b1ab041c52d8021ceea9dd8ff398 (patch)
treef6a9e66012620c6bbbad262b1402364b68bb55de
parentdev-python/sphinx_rtd_theme: Bump to 1.0.0 (diff)
downloadgentoo-466c1bd3.tar.gz
gentoo-466c1bd3.tar.bz2
gentoo-466c1bd3.zip
dev-python/django-otp: Bump to 1.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/django-otp/Manifest1
-rw-r--r--dev-python/django-otp/django-otp-1.1.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/django-otp/Manifest b/dev-python/django-otp/Manifest
index d408f76583e1..d73c9ad2c64b 100644
--- a/dev-python/django-otp/Manifest
+++ b/dev-python/django-otp/Manifest
@@ -1 +1,2 @@
DIST django-otp-1.0.6.gh.tar.gz 69023 BLAKE2B 82534fb666e27ab654b1587160fd9fd4600d1ecb57f5b506b383c3d7b36a13d6bbff39598603c7c3bc69edc871a6a3ad1aa2531a92ea921ab07798e7e4bb1316 SHA512 ff14a786bc8b3d22c8767fa78d676951c262389dfe00def981c79894d299f393ffc86510c33866482aa246ac1643238a3de5701bb76cf56aea5e3ba0a25cbb97
+DIST django-otp-1.1.0.gh.tar.gz 71399 BLAKE2B 826677582fff6102b3e65750c367607e9641aa629a59f064af7023774017f6e7817f36e51e0fada181fa84054545367689b8b499ef9625729c8434a903911876 SHA512 b23c0e72508c890f7a84b59b7827f093aeaad77e6df7c824894bc789282db6f8a26699c9a3ee9bf755eb8e13c6fe5a80fad263659be7528762a8cc29d4636e11
diff --git a/dev-python/django-otp/django-otp-1.1.0.ebuild b/dev-python/django-otp/django-otp-1.1.0.ebuild
new file mode 100644
index 000000000000..892604810582
--- /dev/null
+++ b/dev-python/django-otp/django-otp-1.1.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Django framework adding two-factor authentication using one-time passwords"
+HOMEPAGE="https://github.com/django-otp/django-otp/"
+SRC_URI="
+ https://github.com/django-otp/django-otp/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/django-2.2[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ $(python_gen_impl_dep sqlite)
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/qrcode[${PYTHON_USEDEP}]
+ ${RDEPEND}
+ )"
+
+python_test() {
+ local -x PYTHONPATH=test:${PYTHONPATH}
+ local -x DJANGO_SETTINGS_MODULE=test_project.settings
+ django-admin test -v 2 django_otp || die "Tests fail with ${EPYTHON}"
+}