summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2020-11-05 13:38:01 -0500
committerMike Gilbert <floppym@gentoo.org>2020-11-05 13:38:01 -0500
commit466c34fd3e7836a9b180dcf320023596a1df0567 (patch)
tree35e3585c0d568921f787af602a7d7428eba1b5ca
parentmedia-sound/ncmpcpp: Add myself as maintainer (diff)
downloadgentoo-466c34fd3e7836a9b180dcf320023596a1df0567.tar.gz
gentoo-466c34fd3e7836a9b180dcf320023596a1df0567.tar.bz2
gentoo-466c34fd3e7836a9b180dcf320023596a1df0567.zip
net-misc/openssh: disable utmp and wtmp on musl
Closes: https://bugs.gentoo.org/753230 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
-rw-r--r--net-misc/openssh/openssh-8.4_p1-r2.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/net-misc/openssh/openssh-8.4_p1-r2.ebuild b/net-misc/openssh/openssh-8.4_p1-r2.ebuild
index 096917829106..4122763052b2 100644
--- a/net-misc/openssh/openssh-8.4_p1-r2.ebuild
+++ b/net-misc/openssh/openssh-8.4_p1-r2.ebuild
@@ -320,8 +320,16 @@ src_configure() {
$(use_with !elibc_Cygwin hardening) #659210
)
- # stackprotect is broken on musl x86 and ppc
- use elibc_musl && ( use x86 || use ppc ) && myconf+=( --without-stackprotect )
+ if use elibc_musl; then
+ # stackprotect is broken on musl x86 and ppc
+ if use x86 || use ppc; then
+ myconf+=( --without-stackprotect )
+ fi
+
+ # musl defines bogus values for UTMP_FILE and WTMP_FILE
+ # https://bugs.gentoo.org/753230
+ myconf+=( --disable-utmp --disable-wtmp )
+ fi
# The seccomp sandbox is broken on x32, so use the older method for now. #553748
use amd64 && [[ ${ABI} == "x32" ]] && myconf+=( --with-sandbox=rlimit )