summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2019-05-20 10:19:29 -0400
committerCraig Andrews <candrews@gentoo.org>2019-05-20 10:39:36 -0400
commit466ef2425ce05403b431a2b747acf2cfe2489493 (patch)
tree1cc7212544d423ecded2c7aa7222e8e3b99c08bb
parentwww-client/opera-developer: Version 62.0.3323.0 (diff)
downloadgentoo-466ef242.tar.gz
gentoo-466ef242.tar.bz2
gentoo-466ef242.zip
net-p2p/cpuminer-opt: 3.9.0 version bump, EAPI=7
Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Craig Andrews <candrews@gentoo.org>
-rw-r--r--net-p2p/cpuminer-opt/Manifest1
-rw-r--r--net-p2p/cpuminer-opt/cpuminer-opt-3.9.0.ebuild50
-rw-r--r--net-p2p/cpuminer-opt/cpuminer-opt-9999.ebuild2
3 files changed, 52 insertions, 1 deletions
diff --git a/net-p2p/cpuminer-opt/Manifest b/net-p2p/cpuminer-opt/Manifest
index 00fee98d265b..909943814532 100644
--- a/net-p2p/cpuminer-opt/Manifest
+++ b/net-p2p/cpuminer-opt/Manifest
@@ -1 +1,2 @@
DIST cpuminer-opt-3.8.8.1.tar.gz 1709515 BLAKE2B cecf9f57093fd89cef459cdc0d591a5de4bb12126a931dd9bfee0fc9b08a7ec4b5bb087ad383f14492b3da3066bac695f0022e1dfc595c7e331c9517b4b44db6 SHA512 5dd254237231abb84312c31be97952d1e1f1cd6c4fa0efc409581afb1a28d9783816b9efdb07501d67b99b831bce0a290e5cc2b3ce6c915a3e76b00edd582560
+DIST cpuminer-opt-3.9.0.tar.gz 1744113 BLAKE2B 0fef9ead2218284032d70df4d823f43896a72a06c91612b3a9981a89bb51c890d3fe54707af80d2ebe3ceb513ef98c3e7b036b9ec0a9767ff5b969bed2a26318 SHA512 beb3faf8f2b765f7f995274e247b59590c3cebf2f6d46ce39abac8ecec322cabfc4b2acc087686f9c701c2c32d96b5d1f95d34413ec70c727b58f67054fc2603
diff --git a/net-p2p/cpuminer-opt/cpuminer-opt-3.9.0.ebuild b/net-p2p/cpuminer-opt/cpuminer-opt-3.9.0.ebuild
new file mode 100644
index 000000000000..837ad5101bc1
--- /dev/null
+++ b/net-p2p/cpuminer-opt/cpuminer-opt-3.9.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic systemd
+
+DESCRIPTION="Optimized multi algo CPU miner"
+HOMEPAGE="https://github.com/JayDDee/cpuminer-opt"
+IUSE="cpu_flags_x86_sse2 curl libressl"
+LICENSE="GPL-2"
+SLOT="0"
+REQUIRED_USE="cpu_flags_x86_sse2"
+DEPEND="
+ dev-libs/gmp:0
+ dev-libs/jansson
+ >=net-misc/curl-7.15[ssl]
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+"
+RDEPEND="${DEPEND}"
+if [[ ${PV} == "9999" ]] ; then
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/JayDDee/${PN}.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/JayDDee/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ append-ldflags -Wl,-z,noexecstack
+ econf --with-crypto --with-curl
+}
+
+src_install() {
+ default
+ systemd_dounit "${FILESDIR}"/${PN}.service
+ insinto "/etc/${PN}"
+ doins cpuminer-conf.json
+}
+
+src_test() {
+ ./cpuminer --cputest || die
+}
diff --git a/net-p2p/cpuminer-opt/cpuminer-opt-9999.ebuild b/net-p2p/cpuminer-opt/cpuminer-opt-9999.ebuild
index 38cf197f4977..837ad5101bc1 100644
--- a/net-p2p/cpuminer-opt/cpuminer-opt-9999.ebuild
+++ b/net-p2p/cpuminer-opt/cpuminer-opt-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit autotools flag-o-matic systemd