summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2017-05-27 13:35:59 +0100
committerDiego Elio Pettenò <flameeyes@gentoo.org>2017-05-27 13:35:59 +0100
commit467570170ae4964793a660ca1e3aff6a7789f17c (patch)
tree9f607534481f2911b2ae80e3d838d1da6b3c4ada
parentNew app-crypt/ccid version. (diff)
downloadgentoo-467570170ae4964793a660ca1e3aff6a7789f17c.tar.gz
gentoo-467570170ae4964793a660ca1e3aff6a7789f17c.tar.bz2
gentoo-467570170ae4964793a660ca1e3aff6a7789f17c.zip
New sys-apps/pcsc-lite version.
Package-Manager: Portage-2.3.5, Repoman-2.3.1
-rw-r--r--sys-apps/pcsc-lite/Manifest1
-rw-r--r--sys-apps/pcsc-lite/pcsc-lite-1.8.21.ebuild108
2 files changed, 109 insertions, 0 deletions
diff --git a/sys-apps/pcsc-lite/Manifest b/sys-apps/pcsc-lite/Manifest
index a94773804a61..82832fdfbfd9 100644
--- a/sys-apps/pcsc-lite/Manifest
+++ b/sys-apps/pcsc-lite/Manifest
@@ -1 +1,2 @@
DIST pcsc-lite-1.8.20.tar.bz2 745049 SHA256 ec7d0114016c788c1c09859c84860f6cec6c4595436d23245105154b9c046bb2 SHA512 63fea660d71605ebced5600a59ab5b6a735c4ba3697faf7658d91b8e281a7fb2a2bca6831c8f8c8c87b87a54f7fd03ae818a4c496dcbac0afce523e3b6c606b8 WHIRLPOOL 1c758274a884cf5625d31ed4d56938ee147ba276613c701aee1465b70842a9a73daa92b889835decaaca55707da6be798e3b183aef16a64817d969734d19250a
+DIST pcsc-lite-1.8.21.tar.bz2 750879 SHA256 fe3365eb7d4ce0fe891e2b6d6248351c287435ca502103f1f1431b1710e513ad SHA512 bd3740f4444d2201efaa34a312d2a5f6b5808b0b7ff1d5696dce26df67ef198a63a96670d0acac97a6e693b33079afeeeaa6692746875b0ff72d69a2b0835990 WHIRLPOOL 7bc1040262974c94f9c15f48db5370f1ebd6d29f42267cbf73bcbe750974490dcc012f20a56213a17e26f1cb1dbbe2e9f8fbf0fb9c1db80841aa5863ffe4766c
diff --git a/sys-apps/pcsc-lite/pcsc-lite-1.8.21.ebuild b/sys-apps/pcsc-lite/pcsc-lite-1.8.21.ebuild
new file mode 100644
index 000000000000..2dbff6f0639e
--- /dev/null
+++ b/sys-apps/pcsc-lite/pcsc-lite-1.8.21.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+PYTHON_COMPAT=( python2_7 python3_4 )
+
+inherit python-single-r1 systemd udev user multilib-minimal
+
+DESCRIPTION="PC/SC Architecture smartcard middleware library"
+HOMEPAGE="http://pcsclite.alioth.debian.org/"
+
+STUPID_NUM="4216"
+MY_P="${PN}-${PV/_/-}"
+SRC_URI="http://alioth.debian.org/download.php/file/${STUPID_NUM}/${MY_P}.tar.bz2"
+S="${WORKDIR}/${MY_P}"
+
+# GPL-2 is there for the init script; everything else comes from
+# upstream.
+LICENSE="BSD ISC MIT GPL-3+ GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+# This is called libusb so that it doesn't fool people in thinking that
+# it is _required_ for USB support. Otherwise they'll disable udev and
+# that's going to be worse.
+IUSE="python libusb policykit selinux +udev"
+
+REQUIRED_USE="^^ ( udev libusb ) \
+ python? ( ${PYTHON_REQUIRED_USE} )"
+
+# No dependencies need the MULTILIB_DEPS because the libraries are actually
+# standalone, the deps are only needed for the daemon itself.
+CDEPEND="libusb? ( virtual/libusb:1 )
+ udev? ( virtual/udev )
+ policykit? ( >=sys-auth/polkit-0.111 )
+ python? ( ${PYTHON_DEPS} )"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${CDEPEND}
+ !<app-crypt/ccid-1.4.1-r1
+ !<sys-apps/baselayout-2
+ !<sys-apps/openrc-0.11.8
+ selinux? ( sec-policy/selinux-pcscd )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.8.11-polkit-pcscd.patch
+)
+
+DOCS=( AUTHORS DRIVERS HELP README SECURITY ChangeLog )
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+ enewgroup openct # make sure it exists
+ enewgroup pcscd
+ enewuser pcscd -1 -1 /run/pcscd pcscd,openct
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ --disable-maintainer-mode \
+ --enable-usbdropdir="${EPREFIX}/usr/$(get_libdir)/readers/usb" \
+ --enable-ipcdir=/run/pcscd \
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)" \
+ $(multilib_native_use_enable udev libudev) \
+ $(multilib_native_use_enable libusb) \
+ $(multilib_native_use_enable policykit polkit)
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ newinitd "${FILESDIR}"/pcscd-init.7 pcscd
+
+ if use udev; then
+ insinto "$(get_udevdir)"/rules.d
+ doins "${FILESDIR}"/99-pcscd-hotplug.rules
+ fi
+
+ for f in "${ED}/usr/bin/pcsc-spy"; do
+ if use python; then
+ python_fix_shebang "${f}"
+ else
+ rm "${f}"
+ fi
+ done
+}
+
+pkg_postinst() {
+ elog "Starting from version 1.6.5, pcsc-lite will start as user nobody in"
+ elog "the pcscd group, to avoid running as root."
+ elog ""
+ elog "This also means you need the newest drivers available so that the"
+ elog "devices get the proper owner."
+ elog ""
+ elog "Furthermore, a conf.d file is no longer installed by default, as"
+ elog "the default configuration does not require one. If you need to"
+ elog "pass further options to pcscd, create a file and set the"
+ elog "EXTRA_OPTS variable."
+ elog ""
+ if use udev; then
+ elog "Hotplug support is provided by udev rules; you only need to tell"
+ elog "the init system to hotplug it, by setting this variable in"
+ elog "/etc/rc.conf:"
+ elog ""
+ elog " rc_hotplug=\"pcscd\""
+ fi
+}