summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2021-05-25 16:26:51 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2021-05-25 16:27:14 -0700
commit4675bc1a2c77f36edd2c58e5076923382625e0a8 (patch)
tree1fd59fdf02d6b312b0a98a76b72a026003ca7e5b
parentdev-lang/nim: bump up to 1.4.8 (diff)
downloadgentoo-4675bc1a.tar.gz
gentoo-4675bc1a.tar.bz2
gentoo-4675bc1a.zip
app-emulation/containerd: work around makefile race condition
Closes: https://bugs.gentoo.org/765100 Package-Manager: Portage-3.0.19, Repoman-3.0.3 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
-rw-r--r--app-emulation/containerd/containerd-1.3.7.ebuild3
-rw-r--r--app-emulation/containerd/containerd-1.3.9.ebuild3
-rw-r--r--app-emulation/containerd/containerd-1.4.4.ebuild3
3 files changed, 6 insertions, 3 deletions
diff --git a/app-emulation/containerd/containerd-1.3.7.ebuild b/app-emulation/containerd/containerd-1.3.7.ebuild
index bd5fea0fe6c9..de9c94b35575 100644
--- a/app-emulation/containerd/containerd-1.3.7.ebuild
+++ b/app-emulation/containerd/containerd-1.3.7.ebuild
@@ -66,7 +66,8 @@ src_compile() {
export GOPATH="${WORKDIR}/${P}" # ${PWD}/vendor
export GOFLAGS="-v -x -mod=vendor"
- emake "${myemakeargs[@]}" all man
+ emake "${myemakeargs[@]}" man -j1 #nowarn https://bugs.gentoo.org/765100
+ emake "${myemakeargs[@]}" all
}
src_install() {
diff --git a/app-emulation/containerd/containerd-1.3.9.ebuild b/app-emulation/containerd/containerd-1.3.9.ebuild
index c494ec626927..ce0733b1086a 100644
--- a/app-emulation/containerd/containerd-1.3.9.ebuild
+++ b/app-emulation/containerd/containerd-1.3.9.ebuild
@@ -66,7 +66,8 @@ src_compile() {
export GOPATH="${WORKDIR}/${P}" # ${PWD}/vendor
export GOFLAGS="-v -x -mod=vendor"
- emake "${myemakeargs[@]}" all man
+ emake "${myemakeargs[@]}" man -j1 #nowarn https://bugs.gentoo.org/765100
+ emake "${myemakeargs[@]}" all
}
src_install() {
diff --git a/app-emulation/containerd/containerd-1.4.4.ebuild b/app-emulation/containerd/containerd-1.4.4.ebuild
index d4d947ad8f15..18c54a20724a 100644
--- a/app-emulation/containerd/containerd-1.4.4.ebuild
+++ b/app-emulation/containerd/containerd-1.4.4.ebuild
@@ -63,7 +63,8 @@ src_compile() {
export GOPATH="${WORKDIR}/${P}" # ${PWD}/vendor
export GOFLAGS="-v -x -mod=vendor"
- emake "${myemakeargs[@]}" all man
+ emake "${myemakeargs[@]}" man -j1 #nowarn https://bugs.gentoo.org/765100
+ emake "${myemakeargs[@]}" all
}
src_install() {