summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2015-09-07 08:59:44 +0200
committerLars Wendler <polynomial-c@gentoo.org>2015-09-07 08:59:44 +0200
commit46877d4ff1729a03119b5478b120192241379eef (patch)
tree8f79d7ac401b177f1d16fa33bfa923e3651248cf
parentdev-libs/libexplain: Drop old (diff)
downloadgentoo-46877d4ff1729a03119b5478b120192241379eef.tar.gz
gentoo-46877d4ff1729a03119b5478b120192241379eef.tar.bz2
gentoo-46877d4ff1729a03119b5478b120192241379eef.zip
sys-apps/dmidecode: Bump to version 3.0
Package-Manager: portage-2.2.20.1 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--sys-apps/dmidecode/Manifest1
-rw-r--r--sys-apps/dmidecode/dmidecode-3.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/sys-apps/dmidecode/Manifest b/sys-apps/dmidecode/Manifest
index 8e527c5702dd..12c581da92ee 100644
--- a/sys-apps/dmidecode/Manifest
+++ b/sys-apps/dmidecode/Manifest
@@ -1 +1,2 @@
DIST dmidecode-2.12.tar.bz2 55191 SHA256 913ff3055d563a62a420789b8ee33b038de9afa18ea61254760ddf8ab87a5088 SHA512 15d5a6dca04de48267f969f6866079915964a8a3abad083b1720a4425723f9c100770d05c0d475df9609c5b54741f231a587761d1beb1ae6de4b2836d60724c4 WHIRLPOOL 139841a9efd07ecfcb012a24e2c3ea00c79d66828a5d5aa1eeb8b230c1b84f310e5f9282403af9f530f7ead41922f7a3e8a6e8b93e46d7403d69975b95d6a406
+DIST dmidecode-3.0.tar.xz 58704 SHA256 7ec35bb193729c1d593a1460b59d82d24b89102ab23fd0416e6cf4325d077e45 SHA512 fa31190e43ae7a0b61f6313b45f5eba3ab66390accd587129419e48fca931b631cbb331d6893cf0c1bfca94c86ff8c557215166e0881dee93b3af10a86878eb1 WHIRLPOOL 91f8b26c272fbaa06699f3cdb593a731a0d1e777ba81ee432192e41c1f2edda764ed990b570c2dc2fc44d6ce324d5a252c01308811717db1cd2baebe98b7e176
diff --git a/sys-apps/dmidecode/dmidecode-3.0.ebuild b/sys-apps/dmidecode/dmidecode-3.0.ebuild
new file mode 100644
index 000000000000..4cae2bc805ce
--- /dev/null
+++ b/sys-apps/dmidecode/dmidecode-3.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit flag-o-matic toolchain-funcs eutils
+
+DESCRIPTION="DMI (Desktop Management Interface) table related utilities"
+HOMEPAGE="http://www.nongnu.org/dmidecode/"
+SRC_URI="http://savannah.nongnu.org/download/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-solaris"
+IUSE="selinux"
+
+RDEPEND="selinux? ( sec-policy/selinux-dmidecode )"
+DEPEND=""
+
+src_prepare() {
+ sed -i \
+ -e "/^prefix/s:/usr/local:${EPREFIX}/usr:" \
+ -e "/^docdir/s:dmidecode:${PF}:" \
+ -e '/^PROGRAMS !=/d' \
+ Makefile || die
+}
+
+src_compile() {
+ emake \
+ CFLAGS="${CFLAGS} ${CPPFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ CC="$(tc-getCC)"
+}
+
+pkg_postinst() {
+ if [[ ${CHOST} == *-solaris* ]] ; then
+ einfo "dmidecode needs root privileges to read /dev/xsvc"
+ einfo "To make dmidecode useful, either run as root, or chown and setuid the binary."
+ einfo "Note that /usr/sbin/ptrconf and /usr/sbin/ptrdiag give similar"
+ einfo "information without requiring root privileges."
+ fi
+}