summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-17 09:03:03 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-17 09:36:47 +0200
commit469c16eca220b60de40a3161c5b563190ea21ed2 (patch)
tree579c470cb34c18bc711fd1aae331c119314deaec
parentdev-haskell/cpu: drop USE=executable (diff)
downloadgentoo-469c16ec.tar.gz
gentoo-469c16ec.tar.bz2
gentoo-469c16ec.zip
dev-python/aiofiles: Bump to 0.7.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/aiofiles/Manifest1
-rw-r--r--dev-python/aiofiles/aiofiles-0.7.0.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/aiofiles/Manifest b/dev-python/aiofiles/Manifest
index a54b334c38e2..bc815a4a91b8 100644
--- a/dev-python/aiofiles/Manifest
+++ b/dev-python/aiofiles/Manifest
@@ -1,2 +1,3 @@
DIST aiofiles-0.5.0.tar.gz 13332 BLAKE2B ccd044ce9fcd74b2a6419b4f0e9e3977086c9685741dbb734a7f9222ab96dca58b5330ad0d0cd9f10fce03ee123add7101825f047451344fc451c40a4352674e SHA512 89eb1af506bdf5f3f2e9c3afe90f17d521ada1cdeb449dcdc800d4faa4edc1c9ca93811915aa059d8c5a1b0a3aaa40231a46b3d041ca745e071628293bddf1b7
DIST aiofiles-0.6.0.tar.gz 13585 BLAKE2B 4b81e8369f91b0406c9bd5025c4b5da91418dc810065f1979ec862299fd16976105b89282b22a3ae2e0151cc550c927524795d3c5d69c82809faeb4e16179b8d SHA512 2cf9e340eccfef3934bbd86338a235368b99a10e34526e8267232cef14b12e3d79d40350d82874841d5bf7fd0acf779b663288c57d150096f1275586d51583c4
+DIST aiofiles-0.7.0.tar.gz 23245 BLAKE2B 5dcb743912555de9a4c58a37925ca08c4be7065ea78924854d548b32f31f93bdf1b231db840aa9ac822d467ffd8c7f57c506c5f6d550c662013008899da8b716 SHA512 75287266cd86c572db0795074d625dac8b3476c4d8ef9a193ce01ce80a423a4aa39f6e5ec5005fb441375ccb2a2ec84913634919ee5000bfb7623ac77a030b92
diff --git a/dev-python/aiofiles/aiofiles-0.7.0.ebuild b/dev-python/aiofiles/aiofiles-0.7.0.ebuild
new file mode 100644
index 000000000000..9c3987ed4e4e
--- /dev/null
+++ b/dev-python/aiofiles/aiofiles-0.7.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="File support for asyncio"
+HOMEPAGE="https://github.com/Tinche/aiofiles"
+SRC_URI="https://github.com/Tinche/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest