summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-10-01 08:39:02 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-10-01 08:42:03 +0300
commit46b8969910cd986f2ace145e4a4213459983752e (patch)
tree3de5606172c70218d34bd81c65a6d050610a76c0
parentdev-python/subunit: add github upstream metadata (diff)
downloadgentoo-46b89699.tar.gz
gentoo-46b89699.tar.bz2
gentoo-46b89699.zip
dev-python/subunit: add 1.4.0_p20210729, enable py3.10, fix tests
Closes: https://bugs.gentoo.org/800728 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/subunit/Manifest1
-rw-r--r--dev-python/subunit/subunit-1.4.0_p20210729.ebuild99
2 files changed, 100 insertions, 0 deletions
diff --git a/dev-python/subunit/Manifest b/dev-python/subunit/Manifest
index cfcaf554695e..e59f6c68e1f4 100644
--- a/dev-python/subunit/Manifest
+++ b/dev-python/subunit/Manifest
@@ -1 +1,2 @@
DIST subunit-1.4.0.tar.gz 488022 BLAKE2B 4c3a714d02eeed9420074c4e032778a69b716a5cad0079193533e9bc8c0f4576d70b165eb413203ce8a916ac28466e9f5a113d4a7746019d7d09409df9860bae SHA512 5d2e3cb96c09067ef4595c86648f13330c810b19e39c0b35bc9546c57bee957ddcf5cad7b8e3f92bda9b54dcdbf175863e2f6ba94020f880230459be7afdbbcf
+DIST subunit-1.4.0_p20210729.tar.gz 112644 BLAKE2B 56e785c029f3f2896d0ed3d8005c37403e6aa32d05b653db0e3b679d2157820558e578b53133f4f79404a660f37a710aeeec03ff941fd7cd0819020a0d474515 SHA512 90b1ad071fb5246a7446a4c999142566b9d96c39838905e9020b80f2f0aba0b86dd5185bbd25ff7fc65f69ae68e1e53dfde5b2de05755aa97db9248c6faaa9d7
diff --git a/dev-python/subunit/subunit-1.4.0_p20210729.ebuild b/dev-python/subunit/subunit-1.4.0_p20210729.ebuild
new file mode 100644
index 000000000000..2fbb1719b152
--- /dev/null
+++ b/dev-python/subunit/subunit-1.4.0_p20210729.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1 multilib-minimal autotools
+
+MY_COMMIT="c87ffbd904627d777aa1430963dced92a36aa033"
+
+DESCRIPTION="A streaming protocol for test results"
+HOMEPAGE="https://launchpad.net/subunit https://pypi.org/project/python-subunit/"
+SRC_URI="
+ https://github.com/testing-cabal/subunit/archive/${MY_COMMIT}.tar.gz
+ -> ${P}.tar.gz
+"
+S="${WORKDIR}/${PN}-${MY_COMMIT}"
+
+LICENSE="Apache-2.0 BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="static-libs test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/testtools-0.9.34[${PYTHON_USEDEP}]
+ dev-python/extras[${PYTHON_USEDEP}]
+ dev-lang/perl:="
+
+DEPEND="
+ ${RDEPEND}
+ >=dev-libs/check-0.9.11[${MULTILIB_USEDEP}]
+ >=dev-util/cppunit-1.13.2[${MULTILIB_USEDEP}]
+ >=virtual/pkgconfig-0-r1
+ test? (
+ dev-python/fixtures[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/testscenarios[${PYTHON_USEDEP}]
+ )"
+
+PATCHES=(
+ "${FILESDIR}/subunit-1.4.0-werror.patch"
+)
+
+src_prepare() {
+ sed -i -e 's/os.chdir(os.path.dirname(__file__))//' setup.py || die
+
+ # Install perl modules in vendor_perl, bug 534654.
+ export INSTALLDIRS=vendor
+
+ # fails on py3.6
+ sed -i -e 's:test_add_tag:_&:' \
+ python/subunit/tests/test_subunit_tags.py || die
+
+ mv all_tests.py python/ || die
+
+ distutils-r1_src_prepare
+ eautoreconf
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ econf \
+ --enable-shared \
+ $(use_enable static-libs static)
+}
+
+multilib_src_compile() {
+ default
+ multilib_is_native_abi && distutils-r1_src_compile
+}
+
+python_test() {
+ cd python || die
+ "${PYTHON}" -m testtools.run -v all_tests.test_suite || die "Testing failed with ${EPYTHON}"
+}
+
+multilib_src_test() {
+ multilib_is_native_abi && distutils-r1_src_test
+}
+
+multilib_src_install() {
+ local targets=(
+ install-include_subunitHEADERS
+ install-pcdataDATA
+ install-exec-local
+ install-libLTLIBRARIES
+ )
+ emake DESTDIR="${D}" "${targets[@]}"
+
+ multilib_is_native_abi && distutils-r1_src_install
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${D}" -name '*.la' -delete || die
+}