summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2018-01-28 16:22:38 -0500
committerMike Gilbert <floppym@gentoo.org>2018-01-28 16:25:17 -0500
commit46cc6eaa9b024f87198d2c6e8f91ea041e80399b (patch)
treee6fe2b6c8163588761febf8df0c482bb81708a51
parentpackage.mask: Masked =sys-libs/ncurses-6.1 for testing. (diff)
downloadgentoo-46cc6eaa.tar.gz
gentoo-46cc6eaa.tar.bz2
gentoo-46cc6eaa.zip
app-shells/ksh: bump to 93.20180128
Package-Manager: Portage-2.3.19_p11, Repoman-2.3.6_p45
-rw-r--r--app-shells/ksh/Manifest1
-rw-r--r--app-shells/ksh/files/ksh-prefix-r1.patch51
-rw-r--r--app-shells/ksh/ksh-93.20180128.ebuild36
3 files changed, 88 insertions, 0 deletions
diff --git a/app-shells/ksh/Manifest b/app-shells/ksh/Manifest
index a7b9569906b2..caf1dcac4ed9 100644
--- a/app-shells/ksh/Manifest
+++ b/app-shells/ksh/Manifest
@@ -1,3 +1,4 @@
DIST INIT.2014-06-25.tgz 385531 BLAKE2B 9bd7fd46db725e134a6a35197c8793ada92a5aa293fbd21a94893443392cee5978c4526a09c47c19f650fc1b36eef0b0241ece4ebe6d4b6bdf2546195a5c26ad SHA512 9034cdf5b798c134472d786195d0f5d14e7e7a1f8226dcbccf962880cd59cd59d3a5597307587163f90a9187cce0232235cf79bcd66842044b2c624b335ba730
DIST ast-base.2014-06-25.tgz 9609090 BLAKE2B 1a961eee6c4f40abbe92166ea0697c97c97a486165e225c8eceae9899f8cf8df84ba93135d0f64f67e8319d5734c3f9597cd2444a5710f2645639bce9c40bc37 SHA512 3006dd187c6042798ffd6da5aad8d6340bf4fbad687338b2b9797556136966b65d90295eb267dba198a83ea5b651a9a339d9ff48179f3d7e25b3de76c41bf737
DIST ksh-93.20160110.tar.gz 26416127 BLAKE2B 2e3d7f24e1c7292283f2859b86abca6b31c9104949f870cd5b35dc726dd917eefc826363f19a3ae120bba022fca31a4e38c8998c9010ef46a6c186619068b763 SHA512 cf6e13e5f6b0fd62b12cbcd007c09306ba1ff7e733c207be34cb360b6b269b8e75f2134a32775c65626ea6cfbdf1bbffecab22c7b2ff244fe91981b3d8fa8688
+DIST ksh-93.20180128.tar.gz 16076705 BLAKE2B 1787a883827211f7573a97c78c4b7fca10ea9ca91ada66b148942bdbd36039bb420a6a44659010e870303e8840bf34828233130626c997d5bc264301880b35ad SHA512 d88e369aa79a273971756111d3c019a0dea830bb4ae26741fe91f4182ac46a4d178452a36433ee26db64ad8ec7dd2b003bb50acf51868a28ee1c7203a7f10f4a
diff --git a/app-shells/ksh/files/ksh-prefix-r1.patch b/app-shells/ksh/files/ksh-prefix-r1.patch
new file mode 100644
index 000000000000..d2cfd6c0c154
--- /dev/null
+++ b/app-shells/ksh/files/ksh-prefix-r1.patch
@@ -0,0 +1,51 @@
+From b7769b1f336ba533c4510f1b112fecf84a638a08 Mon Sep 17 00:00:00 2001
+From: Mike Gilbert <floppym@gentoo.org>
+Date: Sun, 28 Jan 2018 16:14:42 -0500
+Subject: [PATCH] EPREFIX support
+
+---
+ src/cmd/ksh93/data/msg.c | 14 +++++++-------
+ 1 file changed, 7 insertions(+), 7 deletions(-)
+
+diff --git a/src/cmd/ksh93/data/msg.c b/src/cmd/ksh93/data/msg.c
+index eabe59e2..61512280 100644
+--- a/src/cmd/ksh93/data/msg.c
++++ b/src/cmd/ksh93/data/msg.c
+@@ -182,7 +182,7 @@ const char e_heading[] = "Current option settings";
+ const char e_sptbnl[] = " \t\n";
+ const char e_tolower[] = "tolower";
+ const char e_toupper[] = "toupper";
+-const char e_defpath[] = "/bin:/usr/bin:";
++const char e_defpath[] = "@GENTOO_PORTAGE_EPREFIX@/bin:@GENTOO_PORTAGE_EPREFIX@/usr/bin:";
+ const char e_defedit[] = _pth_ed;
+ const char e_unknown[] = "<command unknown>";
+ const char e_devnull[] = "/dev/null";
+@@ -190,19 +190,19 @@ const char e_traceprompt[] = "+ ";
+ const char e_supprompt[] = "# ";
+ const char e_stdprompt[] = "$ ";
+ const char e_profile[] = "$HOME/.profile";
+-const char e_sysprofile[] = "/etc/profile";
+-const char e_suidprofile[] = "/etc/suid_profile";
+-const char e_sysrc[] = "/etc/ksh.kshrc";
++const char e_sysprofile[] = "@GENTOO_PORTAGE_EPREFIX@/etc/profile";
++const char e_suidprofile[] = "@GENTOO_PORTAGE_EPREFIX@/etc/suid_profile";
++const char e_sysrc[] = "@GENTOO_PORTAGE_EPREFIX@/etc/ksh.kshrc";
+ #if SHOPT_BASH
+-const char e_bash_sysrc[] = "/etc/bash.bashrc";
++const char e_bash_sysrc[] = "@GENTOO_PORTAGE_EPREFIX@/etc/bash/bashrc";
+ const char e_bash_rc[] = "$HOME/.bashrc";
+ const char e_bash_login[] = "$HOME/.bash_login";
+ const char e_bash_logout[] = "$HOME/.bash_logout";
+ const char e_bash_profile[] = "$HOME/.bash_profile";
+ #endif // SHOPT_BASH
+-const char e_crondir[] = "/usr/spool/cron/atjobs";
++const char e_crondir[] = "@GENTOO_PORTAGE_EPREFIX@/usr/spool/cron/atjobs";
+ const char e_prohibited[] = "login setuid/setgid shells prohibited";
+-const char e_suidexec[] = "/etc/suid_exec";
++const char e_suidexec[] = "@GENTOO_PORTAGE_EPREFIX@/etc/suid_exec";
+ const char hist_fname[] = "/.sh_history";
+ const char e_dot[] = ".";
+ const char e_envmarker[] = "A__z";
+--
+2.16.1
+
diff --git a/app-shells/ksh/ksh-93.20180128.ebuild b/app-shells/ksh/ksh-93.20180128.ebuild
new file mode 100644
index 000000000000..32db068808f9
--- /dev/null
+++ b/app-shells/ksh/ksh-93.20180128.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit meson prefix
+
+DESCRIPTION="The Original Korn Shell, 1993 revision (ksh93)"
+HOMEPAGE="http://www.kornshell.com/"
+
+COMMIT="0c8dbe3001d1bbef4f76673dc9c1629d90da9862"
+SRC_URI="https://github.com/att/ast/archive/${COMMIT}/${P}.tar.gz"
+
+LICENSE="CPL-1.0 EPL-1.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="!app-shells/pdksh"
+
+S="${WORKDIR}/ast-${COMMIT}"
+
+PATCHES=(
+ "${FILESDIR}"/ksh-prefix-r1.patch
+)
+
+src_prepare() {
+ default
+ eprefixify src/cmd/ksh93/data/msg.c
+}
+
+src_install() {
+ meson_src_install
+ dodir /bin
+ mv "${ED%/}"{/usr,}/bin/ksh || die
+}