summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2022-12-27 17:06:28 -0800
committerSam James <sam@gentoo.org>2023-01-15 14:16:10 +0000
commit46ddc2d43b3c5adbbb33d1a02222ba0e9c9c1f0c (patch)
tree0fb14895a4f30f16827f579d7b28abf692223ac0
parentwww-client/chromium-bin: add ppc64le without keywords (diff)
downloadgentoo-46ddc2d43b3c5adbbb33d1a02222ba0e9c9c1f0c.tar.gz
gentoo-46ddc2d43b3c5adbbb33d1a02222ba0e9c9c1f0c.tar.bz2
gentoo-46ddc2d43b3c5adbbb33d1a02222ba0e9c9c1f0c.zip
dev-util/rgbds: New package, v0.6.1
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-util/rgbds/Manifest1
-rw-r--r--dev-util/rgbds/metadata.xml20
-rw-r--r--dev-util/rgbds/rgbds-0.6.1.ebuild37
-rw-r--r--dev-util/rgbds/rgbds-9999.ebuild37
4 files changed, 95 insertions, 0 deletions
diff --git a/dev-util/rgbds/Manifest b/dev-util/rgbds/Manifest
new file mode 100644
index 000000000000..d704150cb693
--- /dev/null
+++ b/dev-util/rgbds/Manifest
@@ -0,0 +1 @@
+DIST rgbds-0.6.1.tar.gz 8041890 BLAKE2B cd5483e6fa5e2ca3bc9a6e3de44fdf7dc92289d558ac72d8922c0cf21b9dc576b878bfd7610cb41f791ad16cc415e446c925ee0dbc77ec4370d6ef4549935681 SHA512 b4a111e3d98a190d3c9b500dc59585fe68a8e6febc79b6716b406b96714e401bac427336388409ae456ee0f1e5a2c285bfe7b4bfa10e0d148ffc161adefe435b
diff --git a/dev-util/rgbds/metadata.xml b/dev-util/rgbds/metadata.xml
new file mode 100644
index 000000000000..d3ec151f4b91
--- /dev/null
+++ b/dev-util/rgbds/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM 'https://www.gentoo.org/dtd/metadata.dtd'>
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>orbea@riseup.net</email>
+ <name>orbea</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ RGBDS (Rednex Game Boy Development System) is a free assembler
+ and linker package for the Game Boy and Game Boy Color.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/gbdev/rgbds/issues</bugs-to>
+ <remote-id type="github">gbdev/rgbds</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-util/rgbds/rgbds-0.6.1.ebuild b/dev-util/rgbds/rgbds-0.6.1.ebuild
new file mode 100644
index 000000000000..9245f4deb4f2
--- /dev/null
+++ b/dev-util/rgbds/rgbds-0.6.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Rednex Game Boy Development System"
+HOMEPAGE="https://rgbds.gbdev.io/"
+if [[ "${PV}" == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/gbdev/${PN}.git"
+else
+ SRC_URI="https://github.com/gbdev/${PN}/archive/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="ZLIB"
+SLOT="0"
+
+DEPEND="media-libs/libpng"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_compile() {
+ append-flags -DNDEBUG
+
+ emake Q= \
+ CC="$(tc-getCC)" \
+ CXX="$(tc-getCXX)" \
+ PKG_CONFIG="$(tc-getPKG_CONFIG)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}"/usr Q= STRIP= install
+ dodoc README.rst
+}
diff --git a/dev-util/rgbds/rgbds-9999.ebuild b/dev-util/rgbds/rgbds-9999.ebuild
new file mode 100644
index 000000000000..9245f4deb4f2
--- /dev/null
+++ b/dev-util/rgbds/rgbds-9999.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Rednex Game Boy Development System"
+HOMEPAGE="https://rgbds.gbdev.io/"
+if [[ "${PV}" == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/gbdev/${PN}.git"
+else
+ SRC_URI="https://github.com/gbdev/${PN}/archive/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="ZLIB"
+SLOT="0"
+
+DEPEND="media-libs/libpng"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_compile() {
+ append-flags -DNDEBUG
+
+ emake Q= \
+ CC="$(tc-getCC)" \
+ CXX="$(tc-getCXX)" \
+ PKG_CONFIG="$(tc-getPKG_CONFIG)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}"/usr Q= STRIP= install
+ dodoc README.rst
+}