summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2022-01-27 10:15:16 -0600
committerWilliam Hubbs <williamh@gentoo.org>2022-01-27 10:15:57 -0600
commit46defa97ff3e85e124efb5bba60f3f31616f1e6f (patch)
treeaaa8dd949dfca6e86a8f05a0b98a7ff44b5607b8
parentapp-doc/phrack-all: add issue 70. (diff)
downloadgentoo-46defa97.tar.gz
gentoo-46defa97.tar.bz2
gentoo-46defa97.zip
dev-libs/liblouis: 3.20.0 bump
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: William Hubbs <williamh@gentoo.org>
-rw-r--r--dev-libs/liblouis/Manifest1
-rw-r--r--dev-libs/liblouis/liblouis-3.20.0.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/dev-libs/liblouis/Manifest b/dev-libs/liblouis/Manifest
index 2a111bfcdeb2..f2c63f1968ea 100644
--- a/dev-libs/liblouis/Manifest
+++ b/dev-libs/liblouis/Manifest
@@ -1,2 +1,3 @@
DIST liblouis-3.13.0.tar.gz 14683684 BLAKE2B 9596fac30ee8512498826ea11c3fe4d9dfba6706166938852242533f1fadde9ca8e363ea1364ebb4266b366ee49863d84ad757f8634d90e48dd8c562c31e9e8d SHA512 68f0205dc55a106c5707f959c1c0d3c121dfe62f263a664e6bec0780bee65cce2fb5d7033ae1c8312d1d79f7ccaf650af71906e8651b60f11219758e41051b61
DIST liblouis-3.17.0.tar.gz 14868166 BLAKE2B 2edc5ef4366e29080d0d138fe45d946730e04dea278a14751106a25862f6266fe0fda492e12f4d2aa7d26d7277a11dfa2eaf8be39cdeffbcf83f2c143922e6d6 SHA512 9511e0f76ef6def3fa30f0bce4df188b2a11251e8ced0a76a92e172026e6751bc19b2c8ccd5789043b65398190a367bca03b3f1449344750e63ebd0fde60b4e3
+DIST liblouis-3.20.0.tar.gz 15119793 BLAKE2B ed8eb9df0364818c73b1ac8afa5311cdcf8bb47b142607ceeced731655ed14a3d5be83465dd923164902b807424a5e1180fc4ae7fd3ef9ed50065f6e6e9b3b0e SHA512 edc94f1f91fbaffcc13c6dbe7958c7f41dac3328038b25bb446d54dc3e26d904da0d0d5e19268cee6b6de3ef228dcd45ff50164ccd148939e6440fe8b5d4b428
diff --git a/dev-libs/liblouis/liblouis-3.20.0.ebuild b/dev-libs/liblouis/liblouis-3.20.0.ebuild
new file mode 100644
index 000000000000..ed9d9ebc447f
--- /dev/null
+++ b/dev-libs/liblouis/liblouis-3.20.0.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_OPTIONAL=1
+inherit distutils-r1
+
+DESCRIPTION="An open-source braille translator and back-translator"
+HOMEPAGE="https://github.com/liblouis/liblouis"
+SRC_URI="https://github.com/liblouis/liblouis/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0/20"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="python test"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+RESTRICT="!test? ( test )"
+
+RDEPEND="python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}"
+BDEPEND="sys-apps/help2man
+ python? ( ${PYTHON_DEPS}
+ >=dev-python/setuptools-42.0.2[${PYTHON_USEDEP}]
+ )
+ test? ( dev-libs/libyaml )
+"
+
+src_prepare() {
+ default
+
+ if use python; then
+ pushd python > /dev/null
+ distutils-r1_src_prepare
+ popd > /dev/null
+ fi
+}
+
+src_configure() {
+ econf \
+ --enable-ucs4 \
+ --disable-static
+}
+
+src_compile() {
+ default
+
+ if use python; then
+ pushd python > /dev/null
+ # setup.py imports liblouis to get the version number,
+ # and this causes the shared library to be dlopened
+ # at build-time. Hack around it with LD_PRELOAD.
+ # Thanks ArchLinux.
+ LD_PRELOAD+=':../liblouis/.libs/liblouis.so'
+ distutils-r1_src_compile
+ popd > /dev/null
+ fi
+}
+
+src_install() {
+ if use python; then
+ pushd python > /dev/null
+ LD_PRELOAD+=':../liblouis/.libs/liblouis.so' \
+ distutils-r1_src_install
+ popd > /dev/null
+ fi
+
+ # These need to be after distutils src_install, or it'll try to install them from under python/ as well
+ DOCS=( README AUTHORS NEWS ChangeLog doc/liblouis.txt )
+ HTML_DOCS=( doc/liblouis.html )
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+}