summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-05-30 17:33:33 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2022-05-30 18:09:02 +0200
commit46ebee1ecc827efdf49097f41fd812cc36f90ec9 (patch)
tree31b759078c68a9ee776ef8983cddef623dbca16d
parentdev-qt/qtwebengine: Re-add KEYWORDS to 5.15.4_p20220526 (diff)
downloadgentoo-46ebee1e.tar.gz
gentoo-46ebee1e.tar.bz2
gentoo-46ebee1e.zip
kde-frameworks/knewstuff: Fix QtQuickDialogWrapper dialog for konsole
Upstream commit b634b65dd081746ccb8bdfa9bf2d878d13e2c0fb KDE-bug: https://bugs.kde.org/show_bug.cgi?id=452593 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-frameworks/knewstuff/files/knewstuff-5.94.0-fix-QtQuickDialogWrapper-for-konsole.patch54
-rw-r--r--kde-frameworks/knewstuff/knewstuff-5.94.0-r1.ebuild51
2 files changed, 105 insertions, 0 deletions
diff --git a/kde-frameworks/knewstuff/files/knewstuff-5.94.0-fix-QtQuickDialogWrapper-for-konsole.patch b/kde-frameworks/knewstuff/files/knewstuff-5.94.0-fix-QtQuickDialogWrapper-for-konsole.patch
new file mode 100644
index 000000000000..002d4c182b28
--- /dev/null
+++ b/kde-frameworks/knewstuff/files/knewstuff-5.94.0-fix-QtQuickDialogWrapper-for-konsole.patch
@@ -0,0 +1,54 @@
+From b634b65dd081746ccb8bdfa9bf2d878d13e2c0fb Mon Sep 17 00:00:00 2001
+From: Alexander Lohnau <alexander.lohnau@gmx.de>
+Date: Tue, 24 May 2022 12:58:54 +0200
+Subject: [PATCH] Fix QtQuickDialogWrapper dialog not being usable in konsole
+
+Patch provided by David Edmundson.
+
+```
+Issue is QGuiApplicationPrivate::showModalWindow
+
+it marks every other non-modal window as blocked, including new windows.
+
+when we focus the new dialog at a wayland/X level Qt gets it, but in it's own internal dispatching ignores that and sends it to the modal window
+
+Qt is smart enough to handle child windows appropriately, but only if it knows about them. Having a transient parent should take care of this. We should have this anyway as that will fix some window placement bugs.
+```
+
+BUG: 452593
+---
+ src/qtquickdialogwrapper.cpp | 7 +++++++
+ 1 file changed, 7 insertions(+)
+
+diff --git a/src/qtquickdialogwrapper.cpp b/src/qtquickdialogwrapper.cpp
+index 4f22b650..e31e8d80 100644
+--- a/src/qtquickdialogwrapper.cpp
++++ b/src/qtquickdialogwrapper.cpp
+@@ -7,10 +7,12 @@
+ #include "qtquickdialogwrapper.h"
+
+ #include <QEventLoop>
++#include <QGuiApplication>
+ #include <QQmlComponent>
+ #include <QQmlContext>
+ #include <QQmlEngine>
+ #include <QTimer>
++#include <QWindow>
+
+ #include <KLocalizedContext>
+
+@@ -70,6 +72,11 @@ QtQuickDialogWrapper::QtQuickDialogWrapper(const QString &configFile, QObject *p
+
+ // Forward relevant signals
+ connect(d->item, SIGNAL(closed()), this, SIGNAL(closed()));
++
++ // Otherwise, the dialog is not in front of other popups, BUG: 452593
++ auto window = qobject_cast<QWindow *>(d->item);
++ Q_ASSERT(window);
++ window->setTransientParent(QGuiApplication::focusWindow());
+ }
+ }
+
+--
+GitLab
+
diff --git a/kde-frameworks/knewstuff/knewstuff-5.94.0-r1.ebuild b/kde-frameworks/knewstuff/knewstuff-5.94.0-r1.ebuild
new file mode 100644
index 000000000000..73336dd92ec0
--- /dev/null
+++ b/kde-frameworks/knewstuff/knewstuff-5.94.0-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_TEST="false"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.3
+inherit ecm kde.org
+
+DESCRIPTION="Framework for downloading and sharing additional application data"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="opds"
+
+DEPEND="
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtxml-${QTMIN}:5
+ =kde-frameworks/attica-${PVCUT}*:5
+ =kde-frameworks/karchive-${PVCUT}*:5
+ =kde-frameworks/kcompletion-${PVCUT}*:5
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kiconthemes-${PVCUT}*:5
+ =kde-frameworks/kio-${PVCUT}*:5
+ =kde-frameworks/kitemviews-${PVCUT}*:5
+ =kde-frameworks/kpackage-${PVCUT}*:5
+ =kde-frameworks/kservice-${PVCUT}*:5
+ =kde-frameworks/ktextwidgets-${PVCUT}*:5
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
+ =kde-frameworks/kxmlgui-${PVCUT}*:5
+ opds? ( =kde-frameworks/syndication-${PVCUT}*:5 )
+"
+RDEPEND="${DEPEND}
+ >=kde-frameworks/kirigami-${PVCUT}:5
+"
+
+PATCHES=( "${FILESDIR}/${P}-fix-QtQuickDialogWrapper-for-konsole.patch" ) # KDE-bug 452593
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package opds KF5Syndication)
+ )
+
+ ecm_src_configure
+}