summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2020-09-29 13:51:02 +0200
committerLouis Sautier <sbraz@gentoo.org>2020-09-29 13:52:11 +0200
commit47005cc59efdae83de8304ffcba23927e0796275 (patch)
tree16e35d156fa9c6ea49aa633debfdc37f1c8c8902
parentsys-kernel/gentoo-sources: Remove EOL'd 5.7.X series (diff)
downloadgentoo-47005cc5.tar.gz
gentoo-47005cc5.tar.bz2
gentoo-47005cc5.zip
dev-python/jwcrypto: bump to 0.8.0, add PyPy3+Py3.{8,9}, doc
Also fix dependencies. Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
-rw-r--r--dev-python/jwcrypto/Manifest1
-rw-r--r--dev-python/jwcrypto/jwcrypto-0.8.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/jwcrypto/Manifest b/dev-python/jwcrypto/Manifest
index 30b45aaa1daf..94dd7040e1cd 100644
--- a/dev-python/jwcrypto/Manifest
+++ b/dev-python/jwcrypto/Manifest
@@ -1 +1,2 @@
DIST jwcrypto-0.7.0.tar.gz 80869 BLAKE2B 7b8a6928dff40d4d3e0bd61cfc81362ed5d0abd1001e1273aa12111166ed13e510d9cff935724578c2b7392bc74ffc94b0a733ea23f4a982e6bd8d35b1155ef4 SHA512 1d2b6268a54f3a3d466f7a7f7f0776164f0f35420b026c8ebfba099df530d965697eea85a49a73c44713e38fdb9ec4018cd4813b8e154a18117fc4006aa5578e
+DIST jwcrypto-0.8.0.tar.gz 81782 BLAKE2B a3cfb04f099a747c365f870c53d75574cdfaf8b98373f37cc107ebca956b414b7d7cb78f8fcd6d3964528d3bc8a217e5c645bf6e82531e951dfdd9ca03472111 SHA512 784134d27ff7abd31e1069763969513ed45f81fd2c242b7ff7036413c35ef374d535eae0123f5561a8e4eb2630cee40056d1c66454288e1310c4cbedecaac210
diff --git a/dev-python/jwcrypto/jwcrypto-0.8.0.ebuild b/dev-python/jwcrypto/jwcrypto-0.8.0.ebuild
new file mode 100644
index 000000000000..0bfd1c99c35e
--- /dev/null
+++ b/dev-python/jwcrypto/jwcrypto-0.8.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Implements JWK,JWS,JWE specifications using python-cryptography"
+
+HOMEPAGE="https://github.com/latchset/jwcrypto"
+SRC_URI="https://github.com/latchset/jwcrypto/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=dev-python/cryptography-2.3[${PYTHON_USEDEP}]"
+
+distutils_enable_sphinx docs/source
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Do not install doc in non-standard paths
+ sed -i "\|data_files = \[('share/doc/jwcrypto|d" setup.py || die
+ distutils-r1_python_prepare_all
+}