summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Seifert <mseifert@error-reports.org>2016-03-22 20:03:02 +0100
committerPatrice Clement <monsieurp@gentoo.org>2016-03-30 12:03:42 +0000
commit4720572e0dcdf0638d64a59b13816bd73449fb73 (patch)
treee0fb815f1e49f7145fe23809498fc1508c59a49b
parentdev-util/buildbot: Added pkg_config. (diff)
downloadgentoo-4720572e0dcdf0638d64a59b13816bd73449fb73.tar.gz
gentoo-4720572e0dcdf0638d64a59b13816bd73449fb73.tar.bz2
gentoo-4720572e0dcdf0638d64a59b13816bd73449fb73.zip
dev-util/buildbot: Added migration guide and updated setup instructions.
buildbot-0.8.12-r2 prints ewarn messages when migrating from a previous version. The messages describe the necessary steps to migrate properly. In addition to this, the user is notified of the support for emerge --config and DOC_CONTENT was updated to point to the possibility of using it. This string of 5 commits merges gentoo/gentoo#1027 and solves bug #570666. Gentoo-Bug: https://bugs.gentoo.org/570666 Acked-By: Markos Chandras hwoarang@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/1027 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
-rw-r--r--dev-util/buildbot/buildbot-0.8.12-r2.ebuild49
1 files changed, 31 insertions, 18 deletions
diff --git a/dev-util/buildbot/buildbot-0.8.12-r2.ebuild b/dev-util/buildbot/buildbot-0.8.12-r2.ebuild
index 1df44223ed9b..b6d42d5795e0 100644
--- a/dev-util/buildbot/buildbot-0.8.12-r2.ebuild
+++ b/dev-util/buildbot/buildbot-0.8.12-r2.ebuild
@@ -46,11 +46,8 @@ pkg_setup() {
DOC_CONTENTS="The \"buildbot\" user and the \"buildmaster\" init script has been added
to support starting buildbot through Gentoo's init system. To use this,
- set up your build master following the documentation, make sure the
- resulting directories are owned by the \"buildbot\" user and point
- \"${EROOT}etc/conf.d/buildmaster\" at the right location. The scripts can
- run as a different user if desired. If you need to run more than one
- build master, just copy the scripts."
+ execute \"emerge --config =${CATEGORY}/${PF}\" to create a new instance.
+ The scripts can run as a different user if desired."
}
src_compile() {
@@ -93,6 +90,20 @@ pkg_postinst() {
readme.gentoo_print_elog
if [[ -n ${REPLACING_VERSIONS} ]]; then
+ ewarn
+ ewarn "Starting with buildbot-0.8.12-r2, more than one instance of buildmaster"
+ ewarn "can be run simultaneously. Note that \"BASEDIR\" in the buildbot configuration file"
+ ewarn "is now the common base directory for all instances. If you are migrating from an older"
+ ewarn "version, make sure that you copy the current contents of \"BASEDIR\" to a subdirectory."
+ ewarn "The name of the subdirectory corresponds to the name of the buildmaster instance."
+ ewarn "In order to start the service running OpenRC-based systems need to link to the init file:"
+ ewarn " ln --symbolic --relative /etc/init.d/buildmaster /etc/init.d/buildmaster.myinstance"
+ ewarn " rc-update add buildmaster.myinstance default"
+ ewarn " /etc/init.d/buildmaster.myinstance start"
+ ewarn "Systems using systemd can do the following:"
+ ewarn " systemctl enable buildmaster@myinstance.service"
+ ewarn " systemctl enable buildmaster.target"
+ ewarn " systemctl start buildmaster.target"
elog
elog "Upstream recommends the following when upgrading:"
elog "Each time you install a new version of Buildbot, you should run the"
@@ -100,23 +111,26 @@ pkg_postinst() {
elog "This will add files and fix (or at least detect) incompatibilities between"
elog "your old config and the new code."
fi
+ elog
+ elog "In order to create a new instance of buildmaster, execute:"
+ elog " emerge --config =${CATEGORY}/${PF}"
}
pkg_config() {
local buildmaster_path="/var/lib/buildmaster"
- einfo "This will prepare a new buildmaster instance in ${buildmaster_path}."
+ einfo "This will prepare a new buildmaster instance in ${buildmaster_path}."
einfo "Press Control-C to abort."
- einfo "Enter the name for the new instance: "
- read instance_name
- [[ -z "${instance_name}" ]] && die "Invalid instance name"
+ einfo "Enter the name for the new instance: "
+ read instance_name
+ [[ -z "${instance_name}" ]] && die "Invalid instance name"
- local instance_path="${buildmaster_path}/${instance_name}"
- if [[ -e "${instance_path}" ]]; then
- eerror "The instance with the specified name already exists:"
- eerror "${instance_path}"
- die "Instance already exists"
- fi
+ local instance_path="${buildmaster_path}/${instance_name}"
+ if [[ -e "${instance_path}" ]]; then
+ eerror "The instance with the specified name already exists:"
+ eerror "${instance_path}"
+ die "Instance already exists"
+ fi
local buildbot="/usr/bin/buildbot"
if [[ ! -d "${buildmaster_path}" ]]; then
@@ -129,7 +143,6 @@ pkg_config() {
ln --symbolic --relative "/etc/init.d/buildmaster" "/etc/init.d/buildmaster.${instance_name}" \
|| die "Unable to create link to init file"
- einfo "Successfully created a buildmaster instance at ${instance_path}."
- einfo "To change the default settings edit the master.cfg file in this directory."
+ einfo "Successfully created a buildmaster instance at ${instance_path}."
+ einfo "To change the default settings edit the master.cfg file in this directory."
}
-