summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristophe Lermytte <gentoo@lermytte.be>2021-09-24 03:28:32 +0200
committerJoonas Niilola <juippis@gentoo.org>2021-09-24 10:21:55 +0300
commit472095f7a63cd1858b9be22813e6752945abffc9 (patch)
tree3d3c8a1c4c94425f17000e9e01cf789dac587d22
parentapp-crypt/swtpm: add a subslot binder for gnutls (diff)
downloadgentoo-472095f7a63cd1858b9be22813e6752945abffc9.tar.gz
gentoo-472095f7a63cd1858b9be22813e6752945abffc9.tar.bz2
gentoo-472095f7a63cd1858b9be22813e6752945abffc9.zip
app-crypt/coolkey: don't parallel install
Something fishy going on in docs/Makefile install-data-hook: rm -f $(DESTDIR)$(libdir)/libckyapplet.a rm -f $(DESTDIR)$(libdir)/libckyapplet.la but agreed with sam that it's not worth it to debug further (seeing that upstream is dead and the src_compile is being done -j1 as well.) - Override src_install with its default but using '-j1' - Update the copyright Signed-off-by: Christophe Lermytte <gentoo@lermytte.be> Closes: https://github.com/gentoo/gentoo/pull/22381 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--app-crypt/coolkey/coolkey-1.1.0-r7.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/app-crypt/coolkey/coolkey-1.1.0-r7.ebuild b/app-crypt/coolkey/coolkey-1.1.0-r7.ebuild
index cbb3e7161b80..61d16c1b67b4 100644
--- a/app-crypt/coolkey/coolkey-1.1.0-r7.ebuild
+++ b/app-crypt/coolkey/coolkey-1.1.0-r7.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -47,6 +47,11 @@ src_compile() {
emake CFLAGS+="-fno-strict-aliasing" -j1
}
+src_install() {
+ emake DESTDIR="${D}" install -j1
+ einstalldocs
+}
+
pkg_postinst() {
if [[ -x $dbdir ]]; then
if ! $(modutil -rawlist -dbdir $dbdir | grep libcoolkeypk11); then