summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-06-27 21:38:52 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-06-27 22:08:35 +0300
commit4725612abee6633d88cf71ac4fecd5a174f51c63 (patch)
tree0e707a6d2d6803d6e3274dc1478317e9c4e1a044
parentdev-python/uvicorn: add 0.18.2 (diff)
downloadgentoo-4725612abee6633d88cf71ac4fecd5a174f51c63.tar.gz
gentoo-4725612abee6633d88cf71ac4fecd5a174f51c63.tar.bz2
gentoo-4725612abee6633d88cf71ac4fecd5a174f51c63.zip
dev-python/mistune: add 2.0.3
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/mistune/Manifest1
-rw-r--r--dev-python/mistune/mistune-2.0.3.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/mistune/Manifest b/dev-python/mistune/Manifest
index 3b80dc584dc4..e55561a46c28 100644
--- a/dev-python/mistune/Manifest
+++ b/dev-python/mistune/Manifest
@@ -1 +1,2 @@
DIST mistune-2.0.2.tar.gz 75778 BLAKE2B 6ed690a70c54a0a06f154d42151d7d857f0e70cfe32529d7176726bd1e2f7a4fb9bf66be476af139c338c9f8b0d0de6541727e18718f6537d3a07771f34441f8 SHA512 8250243bf6cd2496ca1309e1fb062507f37c197817a4c5ec1a8e3c5865b6cc58866b88158b3a2e2967ad53b1f1a668a2e4282c30179ce126242c528000215992
+DIST mistune-2.0.3.tar.gz 75763 BLAKE2B f9508f6a3b955d716947ee8d3876b63a81113a4886dfc3212bdfff00db4c84527b334037eefae4592660ae802e14cab21727c1a50dfbf0ae5223a409688301db SHA512 b6eb9585616af3e1a10d48e469d893d3965048d47a772fd6dcfad4aa026feea8ffe8048c8e93b2d430c07b4bc15e8e8afe43f3a12cbeb8d70872af8b83dc9358
diff --git a/dev-python/mistune/mistune-2.0.3.ebuild b/dev-python/mistune/mistune-2.0.3.ebuild
new file mode 100644
index 000000000000..718413dc53f7
--- /dev/null
+++ b/dev-python/mistune/mistune-2.0.3.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="The fastest markdown parser in pure Python"
+HOMEPAGE="
+ https://github.com/lepture/mistune/
+ https://pypi.org/project/mistune/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+distutils_enable_tests pytest