summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-02-09 11:55:33 +0100
committerHans de Graaff <graaff@gentoo.org>2019-02-10 08:25:15 +0100
commit47323424c44cc7f75a2363ffcd9d9c59e5da54f1 (patch)
tree644d70d4e1a9f847e6aae0db50b530e6141d32a0
parentvirtual/python-futures: amd64 stable wrt bug #676562 (diff)
downloadgentoo-47323424.tar.gz
gentoo-47323424.tar.bz2
gentoo-47323424.zip
dev-ruby/puppet_forge: fix gemspec to match deps in ebuild
Signed-off-by: Hans de Graaff <graaff@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
-rw-r--r--dev-ruby/puppet_forge/puppet_forge-2.2.9.ebuild8
1 files changed, 8 insertions, 0 deletions
diff --git a/dev-ruby/puppet_forge/puppet_forge-2.2.9.ebuild b/dev-ruby/puppet_forge/puppet_forge-2.2.9.ebuild
index 7223fbcbc0f0..e343cdbdd5dc 100644
--- a/dev-ruby/puppet_forge/puppet_forge-2.2.9.ebuild
+++ b/dev-ruby/puppet_forge/puppet_forge-2.2.9.ebuild
@@ -9,6 +9,8 @@ RUBY_FAKEGEM_RECIPE_DOC="rdoc"
RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md"
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
inherit ruby-fakegem
DESCRIPTION="Tools to access Forge API information on Modules, Users, and Releases"
@@ -30,4 +32,10 @@ ruby_add_rdepend "
all_ruby_prepare() {
# Avoid integration and user specs since they all require network access
rm -rf spec/integration spec/unit/forge/v3/user_spec.rb || die
+
+ # Fix overly restrictive dependencies
+ sed -i \
+ -e '/faraday/ s/0.14.0/0.99.0/' \
+ -e '/faraday_middleware/ s/0.13.0/0.99.0/' \
+ ${RUBY_FAKEGEM_GEMSPEC} || die
}