summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-10-21 10:44:56 -0300
committerMart Raudsepp <leio@gentoo.org>2023-10-22 00:21:39 +0300
commit4736b845e2fb36ddc341cc09078e43c10179d7ab (patch)
tree1c83a34c93d92ea283b5dd5ebf3b25eac128b7ca
parentgnome-extra/evolution-ews: Version bump to 3.50.1 (diff)
downloadgentoo-4736b845e2fb36ddc341cc09078e43c10179d7ab.tar.gz
gentoo-4736b845e2fb36ddc341cc09078e43c10179d7ab.tar.bz2
gentoo-4736b845e2fb36ddc341cc09078e43c10179d7ab.zip
sci-geosciences/gnome-maps: Version bump to 45.1
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/33442 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
-rw-r--r--sci-geosciences/gnome-maps/Manifest1
-rw-r--r--sci-geosciences/gnome-maps/gnome-maps-45.1.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/sci-geosciences/gnome-maps/Manifest b/sci-geosciences/gnome-maps/Manifest
index b748acd62ce7..4210c7f31455 100644
--- a/sci-geosciences/gnome-maps/Manifest
+++ b/sci-geosciences/gnome-maps/Manifest
@@ -1,3 +1,4 @@
DIST gnome-maps-44.3.tar.xz 2348292 BLAKE2B 1e66780eaf5ea86e25438702ed8602801d31b128e40e48b30d01b9aecb9366168447f6d47efdc3198d4c8598dbcd439ae9a8c80e3810fc22faf1a3f1a44ea1b3 SHA512 a193b27474a3b62b3dc5ddbe082ea9718c5225d4939d939cf0050c46016fa1c173091d7a6087aa7be53e8369867b200de793a91f87971b8696207a12ec50c682
DIST gnome-maps-44.4.tar.xz 2348376 BLAKE2B c2a17704709cdb8216cfeeeb98c47d0a5b06335f5f9e158175bb4a982db6d385f0c64554f15549e971b00f1fe2bdc215f309abdc37f47fffbb28e76235ec30fe SHA512 7e529f13daa9f1bd24b1e07e5b4514cdc32ed03b27683ee428863daf6fc883ce2cfd4995446335181c71e452e05e199e76f706a207f01f3930f1f340146e55aa
DIST gnome-maps-45.0.tar.xz 3137420 BLAKE2B b44915359353fe924f0ca969d5ef8f321c6b15bcd42a3682e5086a6dacd0fba04444cf83d5ac281a627651f7454827950f27267b0b5c90fb5575983d083146c5 SHA512 052322e9f92e1311e3eb57a06b2dcdd95e1083f99c59426883884802d6d38c1084d9cca8ff9821b2878c0b70d2c15d1ff04a7710658addf6ad024a198edb61db
+DIST gnome-maps-45.1.tar.xz 3140732 BLAKE2B 060ad1c99a6cc87a647f23de4263ef980e8e7f512a9d498e28ff047bca65509c34de15004a4106eed87adeedc9d45ad3875193ddc8791d6b9cbda7623e4d9c10 SHA512 ed738db8929ca62dc8ce6780749f8a370fcd2d7175911521124cb7ac360bd94797ec209b01c7fc1a5520a7c680e8089954e9a88673b3c12b48d009469d6e1eef
diff --git a/sci-geosciences/gnome-maps/gnome-maps-45.1.ebuild b/sci-geosciences/gnome-maps/gnome-maps-45.1.ebuild
new file mode 100644
index 000000000000..4dbc0fd2b0fc
--- /dev/null
+++ b/sci-geosciences/gnome-maps/gnome-maps-45.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="A map application for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Maps"
+
+LICENSE="GPL-2+ LGPL-2+ MIT CC-BY-3.0 CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+# Pure introspection dependencies found by grepping imports in ${S}
+RDEPEND="
+ >=dev-libs/glib-2.66.0:2
+ >=dev-libs/gjs-1.69.2
+ >=dev-libs/gobject-introspection-0.10.1:=
+ gui-libs/gtk:4[introspection]
+ >=app-misc/geoclue-0.12.99:2.0[introspection]
+ >=gui-libs/libadwaita-1.4_alpha:1[introspection]
+ >=dev-libs/libgweather-4.2.0:4=[introspection]
+ >=sci-geosciences/geocode-glib-3.15.2:2[introspection]
+ dev-libs/libportal:=[introspection]
+ >=media-libs/libshumate-1.1_beta:1.0=[introspection]
+ dev-libs/libxml2:2
+ >=net-libs/rest-0.9.1:1.0[introspection]
+
+ app-crypt/libsecret[introspection]
+ media-libs/graphene[introspection]
+ net-libs/libsoup:3.0[introspection]
+ x11-libs/pango[introspection]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}