summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2022-05-07 18:14:19 +0200
committerFlorian Schmaus <flow@gentoo.org>2022-05-09 21:13:20 +0200
commit473a713d284491719ea956ef135214ef4ab4c218 (patch)
tree2d56e4bf8685cf2cb242ec55a917abf772ab1d88
parentdev-java/javahelp: update EAPI 6 -> 8 (diff)
downloadgentoo-473a713d284491719ea956ef135214ef4ab4c218.tar.gz
gentoo-473a713d284491719ea956ef135214ef4ab4c218.tar.bz2
gentoo-473a713d284491719ea956ef135214ef4ab4c218.zip
dev-java/gnu-jaf: update EAPI 6 -> 8
Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Signed-off-by: Florian Schmaus <flow@gentoo.org>
-rw-r--r--dev-java/gnu-jaf/gnu-jaf-1.1.2-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-java/gnu-jaf/gnu-jaf-1.1.2-r1.ebuild b/dev-java/gnu-jaf/gnu-jaf-1.1.2-r1.ebuild
new file mode 100644
index 000000000000..6c4ef7d1e74d
--- /dev/null
+++ b/dev-java/gnu-jaf/gnu-jaf-1.1.2-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source"
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="GNU implementation of the JavaBeans Activation Framework"
+HOMEPAGE="https://www.gnu.org/software/classpathx/jaf/jaf.html"
+SRC_URI="mirror://gnu/classpathx/activation-${PV}.tar.gz"
+
+LICENSE="GPL-2-with-linking-exception"
+SLOT="1"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+DEPEND=">=virtual/jdk-1.8:*"
+RDEPEND=">=virtual/jre-1.8:*"
+
+S="${WORKDIR}/activation-${PV}"
+
+EANT_BUILD_TARGET="activation.jar"
+
+src_install() {
+ java-pkg_dojar activation.jar
+ einstalldocs
+ use doc && java-pkg_dojavadoc docs
+ use source && java-pkg_dosrc source/*
+}