summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2022-06-08 20:10:27 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2022-06-08 20:10:43 -0500
commit476c12b886b7ef0b8b831e7e8bad11b469c733e7 (patch)
tree185448a65d256f1fc5ad55360761f88d155e38a8
parentapp-crypt/certbot-apache: 1.28.0 bump (diff)
downloadgentoo-476c12b886b7ef0b8b831e7e8bad11b469c733e7.tar.gz
gentoo-476c12b886b7ef0b8b831e7e8bad11b469c733e7.tar.bz2
gentoo-476c12b886b7ef0b8b831e7e8bad11b469c733e7.zip
app-crypt/certbot-nginx: 1.28.0 bump
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
-rw-r--r--app-crypt/certbot-nginx/Manifest1
-rw-r--r--app-crypt/certbot-nginx/certbot-nginx-1.28.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/app-crypt/certbot-nginx/Manifest b/app-crypt/certbot-nginx/Manifest
index 7f1791d4f5a1..ba10cdacbdf6 100644
--- a/app-crypt/certbot-nginx/Manifest
+++ b/app-crypt/certbot-nginx/Manifest
@@ -1,2 +1,3 @@
DIST certbot-1.26.0.tar.gz 1364070 BLAKE2B f9b13df8fb424e579293280202b71756c37a3ec7f986da38a5fd318d00ab7e2ed89223c62a20448ad30271783bb3c44db11a0ce4afebced9f1e9ca4e4c6de3f2 SHA512 bd27cb0a0ef6fc143a3d0dcf5d530d336b93a24d7010e6427c25614befb815f33076b4a3043bb247cafdfad17b8714a19ead43257c64f4fd72ac99f02cb07cde
DIST certbot-1.27.0.tar.gz 1366469 BLAKE2B e9ec47520e027a9d348e861ea7d070eff4857301be0d42be6965e4159d85ef60866aa70de76edd5e68b0d40d9544075aa28e9aa07a8e04dfbf3e1a7dd77fd1de SHA512 5db7836ae2eda27c088476c149e736ce7f41b85d871cf563c69e021dd8af2d64ed85c1482049edf0dffe6fd0c9591d66be3e22fbf617068600e12691c4802e5e
+DIST certbot-1.28.0.tar.gz 1367671 BLAKE2B 01fda6c068217e32273b2c1ac97faa099f98da687d41796e1c98971ed6779ab4ff78e3309b7a6f82b9b0a891c5f00b5201bb3ce1bc879e5acbab3ccc4988ec31 SHA512 888f51dfcf4712b70ce7c99abfc52106384dcba2eef486db8b033bfcca3043bd0beaadce1c1e59f19c3a58b7fe454b2b64774de2e23f5d93579b3e1be1a7c08b
diff --git a/app-crypt/certbot-nginx/certbot-nginx-1.28.0.ebuild b/app-crypt/certbot-nginx/certbot-nginx-1.28.0.ebuild
new file mode 100644
index 000000000000..e66a6b39887e
--- /dev/null
+++ b/app-crypt/certbot-nginx/certbot-nginx-1.28.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ inherit git-r3
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/${PN%-nginx}/${PN%-nginx}/archive/v${PV}.tar.gz -> ${PN%-nginx}-${PV}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+ S=${WORKDIR}/${PN%-nginx}-${PV}/${PN}
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="Nginx plugin for certbot (Let's Encrypt Client)"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
+ >=app-crypt/certbot-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-17.3.0[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-2.2.1[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest