summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRonny (tastytea) Gutbrod <gentoo@tastytea.de>2022-07-29 13:21:06 +0200
committerSam James <sam@gentoo.org>2022-07-31 00:22:29 +0100
commit477015c0b557b557c8cd527b93fd5ba8d6b42000 (patch)
tree4c597a2c71446c700e33f28828e4f307c084eb11
parentsci-chemistry/mdtraj: add github upstream metadata (diff)
downloadgentoo-477015c0b557b557c8cd527b93fd5ba8d6b42000.tar.gz
gentoo-477015c0b557b557c8cd527b93fd5ba8d6b42000.tar.bz2
gentoo-477015c0b557b557c8cd527b93fd5ba8d6b42000.zip
x11-themes/gentoo-xcursors: fix blocked symlink installation
A directory was replaced by a symlink but that does not work due to bug #834600. Straight to stable since the broken ebuild landed in stable and the package isn't compiling anything. Closes: https://bugs.gentoo.org/861785 Co-developed-by: John Duncan Signed-off-by: Ronny (tastytea) Gutbrod <gentoo@tastytea.de> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--x11-themes/gentoo-xcursors/gentoo-xcursors-0.3.2-r3.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/x11-themes/gentoo-xcursors/gentoo-xcursors-0.3.2-r3.ebuild b/x11-themes/gentoo-xcursors/gentoo-xcursors-0.3.2-r3.ebuild
new file mode 100644
index 000000000000..a891f268b288
--- /dev/null
+++ b/x11-themes/gentoo-xcursors/gentoo-xcursors-0.3.2-r3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A high quality set of animated mouse cursors"
+HOMEPAGE="https://schlomp.space/tastytea/gentoo-xcursors"
+SRC_URI="https://schlomp.space/tastytea/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86"
+
+src_install() {
+ insinto /usr/share/icons
+ doins -r cursors/*
+
+ # Add symlinks in Gentoo-specific location for backwards compatibility, #848606
+ mkdir -p ${ED}/usr/share/cursors/xorg-x11 || die
+ cd ${ED}/usr/share/cursors/xorg-x11 || die
+ for cursorset in ../../icons/*; do
+ dosym ${cursorset} /usr/share/cursors/xorg-x11/${cursorset##*/}
+ done
+}
+
+pkg_preinst() {
+ # Needed until bug #834600 is solved
+ if [[ -n ${REPLACING_VERSIONS} ]] ; then
+ GENTOOCURSORS="${EROOT}/usr/share/cursors/xorg-x11"
+ if [[ -d "${GENTOOCURSORS}/gentoo" ]] ; then
+ rm -r "${GENTOOCURSORS}/gentoo" || die
+ fi
+ if [[ -d "${GENTOOCURSORS}/gentoo-blue" ]] ; then
+ rm -r "${GENTOOCURSORS}/gentoo-blue" || die
+ fi
+ if [[ -d "${GENTOOCURSORS}/gentoo-silver" ]] ; then
+ rm -r "${GENTOOCURSORS}/gentoo-silver" || die
+ fi
+
+ if [[ -L "${GENTOOCURSORS}"/gentoo.backup.0000 ]]; then
+ einfo "There are symlinks left from a previous failed upgrade."
+ einfo "Remove ${GENTOOCURSORS}/gentoo*.backup.* manually to get rid of them."
+ fi
+ fi
+}
+
+pkg_postinst() {
+ einfo "To use this set of cursors, consult <https://wiki.gentoo.org/wiki/Cursor_themes>."
+ einfo "The three sets installed are gentoo, gentoo-silver and gentoo-blue."
+}