summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-30 07:45:17 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-30 07:45:17 +0200
commit4774f246000b2b836f16dae150de28cad258e99d (patch)
tree97b6ac675090b5e9eff89f2e8d4b1c6dc82a8676
parentdev-libs/rocm-opencl-runtime: Fix building with newer opencl-headers (diff)
downloadgentoo-4774f246000b2b836f16dae150de28cad258e99d.tar.gz
gentoo-4774f246000b2b836f16dae150de28cad258e99d.tar.bz2
gentoo-4774f246000b2b836f16dae150de28cad258e99d.zip
dev-python/google-api-python-client: Bump to 2.11.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/google-api-python-client/Manifest1
-rw-r--r--dev-python/google-api-python-client/google-api-python-client-2.11.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/google-api-python-client/Manifest b/dev-python/google-api-python-client/Manifest
index e10403d58cff..cf2236d3adeb 100644
--- a/dev-python/google-api-python-client/Manifest
+++ b/dev-python/google-api-python-client/Manifest
@@ -1,4 +1,5 @@
DIST google-api-python-client-2.10.0.tar.gz 25252980 BLAKE2B 25932dec798518217eb724b3514de6f45e57543703396516f3d1a4599f40cb258893d2b2c7e706ef341a6217459a08ebfdf61e2d16949bf8831aed2f79fa80c0 SHA512 acc6ff1a6cad0d568e3af2c7fa4ac5fc3f908adcda1bc846aebc473cdf9f63b873fdf3182c44c3afe50a1f26a645be21b7b33335e67afb09210c001ba22365ad
+DIST google-api-python-client-2.11.0.tar.gz 25408815 BLAKE2B 9bc7d0163961f5b6341fcb43f41a91dfe12702254047ac2b418ce89dad4f8f40400a7df1fff5ce9d73a05c5249b7242a4d642b866b97a34140826901f74f9d6e SHA512 6d31e0ed926f87f12400b1ec244f8e193d6559c58d6775c34ef5747af3ba633e76e8a883983438e84c6d31fe81ea57ac522f924270b80993cc6396cb6f3ae60e
DIST google-api-python-client-2.4.0.tar.gz 24853833 BLAKE2B 4ed2083a9bb8b4f8fe31ab5dbd7875c0c36c972cdb0f71a59565fe4eb23ff1ef0a40794acd7af9646c1ee3904fbab3caaeb2700a3660b66d3069d2bc4f811e76 SHA512 db545850b9d2746e3bcf7b4a2f12b0d4827bd68f44d5627fd80d39bff2ca3303c8d520f72ee17637fe700bc935548706ce885ff0d7fe737ae157668e0314fbc6
DIST google-api-python-client-2.7.0.tar.gz 25488451 BLAKE2B a8a761944fed3970ae0cf53b2cb926a6670ac37323c39085a5f7fb4f354451292fca4bbb2c34a72d086dfa961b74a72f66319f6bbc2505ef70f5c94aff3f7a0e SHA512 531e919cc9d0cffc49b31d881a6ee3adb2d9cc166813b5884c300e9a3b63b28c9c269a0d1efe47961fa61f79ec5adb8a12e2208b644fd62ed4baa66c56d219ba
DIST google-api-python-client-2.8.0.tar.gz 25286774 BLAKE2B b21aebda062984b9eb8f2f5c563016f0f8f663883dc8ddb913053ff3df32c652c6a83f924f3e19136e5edec085e12c43cc584bc9898630122c77a219810033bc SHA512 cc3c55438b2f5835b52d17d04a749919c4865991ff78cf95920d0941a55e1493eae502a13f6565cfe1db799ce9950659e8baaa690bada058d711309861c8d07e
diff --git a/dev-python/google-api-python-client/google-api-python-client-2.11.0.ebuild b/dev-python/google-api-python-client/google-api-python-client-2.11.0.ebuild
new file mode 100644
index 000000000000..53fb37378258
--- /dev/null
+++ b/dev-python/google-api-python-client/google-api-python-client-2.11.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Google API Client for Python"
+HOMEPAGE="https://github.com/googleapis/google-api-python-client"
+SRC_URI="https://github.com/googleapis/google-api-python-client/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/httplib2-0.15[${PYTHON_USEDEP}]
+ <dev-python/httplib2-1[${PYTHON_USEDEP}]
+ dev-python/google-api-core[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.16.0[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-httplib2-0.1.0[${PYTHON_USEDEP}]
+ >=dev-python/uritemplate-3.0.0[${PYTHON_USEDEP}]
+ <dev-python/uritemplate-4[${PYTHON_USEDEP}]
+ >=dev-python/six-1.13.0[${PYTHON_USEDEP}]
+ <dev-python/six-2[${PYTHON_USEDEP}]
+ "
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/oauth2client[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ dev-python/unittest2[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests --install pytest
+
+python_test() {
+ local deselect=(
+ # require Internet access (and credentials)
+ tests/test_discovery.py::DiscoveryErrors::test_credentials_and_credentials_file_mutually_exclusive
+ tests/test_discovery.py::DiscoveryFromDocument::test_api_endpoint_override_from_client_options_mapping_object
+ )
+
+ distutils_install_for_testing
+ epytest ${deselect[@]/#/--deselect }
+}