summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-10-30 15:45:02 +0100
committerAlexis Ballier <aballier@gentoo.org>2015-10-30 15:45:33 +0100
commit4775fca7d28824ab148f76a8ed25b24edd364bd8 (patch)
treefc8f34461c5750a871c6c49e2858590d555e9fd4
parentmedia-libs/chromaprint: Add MULTILIB_USEDEP to build deps too. (diff)
downloadgentoo-4775fca7.tar.gz
gentoo-4775fca7.tar.bz2
gentoo-4775fca7.zip
media-video/ffmpeg: Add chromaprint useflag.
Package-Manager: portage-2.2.23
-rw-r--r--media-video/ffmpeg/ffmpeg-9999.ebuild6
-rw-r--r--media-video/ffmpeg/metadata.xml1
2 files changed, 5 insertions, 2 deletions
diff --git a/media-video/ffmpeg/ffmpeg-9999.ebuild b/media-video/ffmpeg/ffmpeg-9999.ebuild
index e02d1bc7a836..5f63b0cebb5a 100644
--- a/media-video/ffmpeg/ffmpeg-9999.ebuild
+++ b/media-video/ffmpeg/ffmpeg-9999.ebuild
@@ -79,8 +79,9 @@ FFMPEG_FLAG_MAP=(
schroedinger:libschroedinger speex:libspeex vorbis:libvorbis vpx:libvpx
zvbi:libzvbi
# libavfilter options
- bs2b:libbs2b flite:libflite frei0r fribidi:libfribidi fontconfig ladspa
- libass truetype:libfreetype rubberband:librubberband zimg:libzimg
+ bs2b:libbs2b chromaprint flite:libflite frei0r fribidi:libfribidi
+ fontconfig ladspa libass truetype:libfreetype rubberband:librubberband
+ zimg:libzimg
# libswresample options
libsoxr
# Threads; we only support pthread for now but ffmpeg supports more
@@ -160,6 +161,7 @@ RDEPEND="
bzip2? ( >=app-arch/bzip2-1.0.6-r4[${MULTILIB_USEDEP}] )
cdio? ( >=dev-libs/libcdio-paranoia-0.90_p1-r1[${MULTILIB_USEDEP}] )
celt? ( >=media-libs/celt-0.11.1-r1[${MULTILIB_USEDEP}] )
+ chromaprint? ( >=media-libs/chromaprint-1.2-r1[${MULTILIB_USEDEP}] )
encode? (
aac? ( >=media-libs/vo-aacenc-0.1.3[${MULTILIB_USEDEP}] )
aacplus? ( >=media-libs/libaacplus-2.0.2-r1[${MULTILIB_USEDEP}] )
diff --git a/media-video/ffmpeg/metadata.xml b/media-video/ffmpeg/metadata.xml
index 0c65704c7bd2..53adfacfd2d3 100644
--- a/media-video/ffmpeg/metadata.xml
+++ b/media-video/ffmpeg/metadata.xml
@@ -17,6 +17,7 @@
<flag name="bs2b">Enables <pkg>media-libs/libbs2b</pkg> based Bauer stereo-to-binaural filter.</flag>
<flag name="cdio">Enables audio CD grabbing with <pkg>dev-libs/libcdio</pkg>.</flag>
<flag name="celt">Adds Xiph CELT audio decoding support via <pkg>media-libs/celt</pkg></flag>
+ <flag name="chromaprint">Enables audio fingerprinting support with <pkg>media-libs/chromaprint</pkg>.</flag>
<flag name="cpudetection">Enables runtime CPU detection (useful for bindist, compatibility on other CPUs)</flag>
<flag name="faac">Use external faac library for AAC encoding</flag>
<flag name="fdk">Use external fdk-aac library for AAC encoding</flag>