summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-27 10:44:09 +0200
committerMichał Górny <mgorny@gentoo.org>2022-03-27 11:31:50 +0200
commit477d835cd127e67dbcd5bde091b50b53d751d03f (patch)
treefb867bb3ffb99f6e9230658fb3bd84dd57958b6f
parentdev-python/moto: Bump to 3.1.2 (diff)
downloadgentoo-477d835cd127e67dbcd5bde091b50b53d751d03f.tar.gz
gentoo-477d835cd127e67dbcd5bde091b50b53d751d03f.tar.bz2
gentoo-477d835cd127e67dbcd5bde091b50b53d751d03f.zip
dev-python/watchdog: Bump to 2.1.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/watchdog/Manifest1
-rw-r--r--dev-python/watchdog/watchdog-2.1.7.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/watchdog/Manifest b/dev-python/watchdog/Manifest
index ef141d1d6707..baca7e7a0a98 100644
--- a/dev-python/watchdog/Manifest
+++ b/dev-python/watchdog/Manifest
@@ -1,2 +1,3 @@
DIST watchdog-1.0.2.tar.gz 91796 BLAKE2B 001cbe82ff8aff0c4e56e4d1f02519047580cccb48466566ad7c9c1f462f90a9a036cf90846eb38ec4fb24ff1df2a1ddfec20b3f0587afdc1f938ada1bb0b1ef SHA512 e87a0955ce822daabd7d030804876698f98ed2aad58486e26a94585763655302063f091b653abd385ea99642361b6253d8e051d96019b243a77b078ba86b0d6e
DIST watchdog-2.1.6.tar.gz 99756 BLAKE2B 5ea08660c28f77be02b261a22e6fbfdfaaa59f79af1eecb396fda2e56ab4b5b290dc2c791b31a6841ac6d96c7974d51e846ce0232e9de6728f6031685685e761 SHA512 810ee2c40d92102815685c6e06bee403dfb85df7c8de5f1b7066b27cef2a8e25f506f8d9cc0ff0ec3213b889a7844138692fd9d1ab0c40d0aa2097c55e85f531
+DIST watchdog-2.1.7.gh.tar.gz 100442 BLAKE2B 21247e1790077eb1eb2f1dc2bb8ddebc1b7f6a2c503238c52c660246fee8c1d3483119184a62114efb81c44665321d4e3aa18ffd73b3244a44c4c6df5204c834 SHA512 f69265aac6e8a840d230c15cfe88c803f043cb540785446113617c0fd1a3c5dce8a885a376bbadc75372a718800948dd4b00c618e18e033d510b8e2bc2bbb36b
diff --git a/dev-python/watchdog/watchdog-2.1.7.ebuild b/dev-python/watchdog/watchdog-2.1.7.ebuild
new file mode 100644
index 000000000000..c7201e2d04e8
--- /dev/null
+++ b/dev-python/watchdog/watchdog-2.1.7.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Python API and shell utilities to monitor file system events"
+HOMEPAGE="https://github.com/gorakhargosh/watchdog"
+SRC_URI="
+ https://github.com/gorakhargosh/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/pytest-timeout-0.3[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/--cov/d' setup.cfg || die
+ default
+}
+
+python_test() {
+ epytest -p no:django
+}
+
+pkg_postinst() {
+ optfeature "Bash completion" dev-python/argcomplete
+}