summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-26 12:24:41 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-26 12:39:38 +0100
commit4793680d705569f3362b956fc2c94fc48a43c4c4 (patch)
tree2b7d0bfd5a910a16327a23eb6bd3b5b9e02455fa
parentdev-python/openpyxl: Migrate to PEP517 build (diff)
downloadgentoo-4793680d.tar.gz
gentoo-4793680d.tar.bz2
gentoo-4793680d.zip
dev-python/twython: Migrate to PEP517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/twython/twython-3.9.1-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/twython/twython-3.9.1-r1.ebuild b/dev-python/twython/twython-3.9.1-r1.ebuild
new file mode 100644
index 000000000000..6e483bc423d5
--- /dev/null
+++ b/dev-python/twython/twython-3.9.1-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="An easy way to access Twitter data with Python"
+HOMEPAGE="https://github.com/ryanmcgrath/twython"
+SRC_URI="
+ https://github.com/ryanmcgrath/twython/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/requests-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-oauthlib-0.4.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/responses[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # tests are largely unmaintained and outdated
+ tests/test_core.py::TwythonAPITestCase::test_get_lastfunction_header_should_return_header
+ tests/test_core.py::TwythonAPITestCase::test_request_should_handle_400_for_missing_auth_data
+ tests/test_core.py::TwythonAPITestCase::test_request_should_handle_400_that_is_not_auth_related
+ tests/test_core.py::TwythonAPITestCase::test_request_should_handle_401
+ tests/test_core.py::TwythonAPITestCase::test_request_should_handle_rate_limit
+ tests/test_core.py::TwythonAPITestCase::test_sends_correct_accept_encoding_header
+)