summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2018-09-05 14:40:40 +0200
committerPatrice Clement <monsieurp@gentoo.org>2018-09-10 15:23:20 +0200
commit479564d03cc2e06c0f9cd78f6581109d9fc5357e (patch)
tree4221f64f1c19137fd79b3203917d8f9120d298de
parentgames-util/springlobby: 0.264 removal (diff)
downloadgentoo-479564d0.tar.gz
gentoo-479564d0.tar.bz2
gentoo-479564d0.zip
dev-python/matplotlib2tikz: version bump to 0.6.18.
Package-Manager: Portage-2.3.40, Repoman-2.3.9 Closes: https://github.com/gentoo/gentoo/pull/9785
-rw-r--r--dev-python/matplotlib2tikz/Manifest1
-rw-r--r--dev-python/matplotlib2tikz/matplotlib2tikz-0.6.18.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/matplotlib2tikz/Manifest b/dev-python/matplotlib2tikz/Manifest
index 0994fa38eb53..8096f92f6f24 100644
--- a/dev-python/matplotlib2tikz/Manifest
+++ b/dev-python/matplotlib2tikz/Manifest
@@ -1 +1,2 @@
DIST matplotlib2tikz-0.6.17.tar.gz 526409 BLAKE2B 704ede0539aeb9668b4c1534b6dd13bb2a5bc18e7861bfdbe2e9002cc5a8b8c4639ac77384e1249c52ef33e04986b85f27dc5219e9c9c7c8b7b03cb5a7bf586c SHA512 9a8f34a69147271bb252a4e04bc5ce27c39fc976c29d1530df109287bbfd163f37a3b5f3d6a03def962e06c2a69e7d256028b12372847fbe14459cc664eca199
+DIST matplotlib2tikz-0.6.18.tar.gz 527262 BLAKE2B 370a1e088a17a98afd29e1e465c93b98b10100c85a277be3130f5c39bc236a9efab9241f9edffdbd430f9645cba4ff00ebda73dddeda024e3f545b21e548e786 SHA512 e12db2dd54a2145e1d66e19158c8a9305243beea60add0559959d801d319c43a28aa779048764d2adf29f878f7ccca9b2363bbc5034135a9d9002a8815fe37ab
diff --git a/dev-python/matplotlib2tikz/matplotlib2tikz-0.6.18.ebuild b/dev-python/matplotlib2tikz/matplotlib2tikz-0.6.18.ebuild
new file mode 100644
index 000000000000..bc9212c7a05a
--- /dev/null
+++ b/dev-python/matplotlib2tikz/matplotlib2tikz-0.6.18.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Convert matplotlib figures into TikZ/PGFPlots"
+HOMEPAGE="https://github.com/nschloe/matplotlib2tikz"
+SRC_URI="https://github.com/nschloe/matplotlib2tikz/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/ImageHash[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-tex/pgf
+ )"
+
+# we have not succeeded in getting the tests to work yet ;-)
+RESTRICT="test"
+
+python_test() {
+ local -x MPLBACKEND=Agg
+ virtx py.test -v || die "Tests failed with ${EPYTHON}"
+}