summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-16 05:37:43 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-16 05:37:43 +0200
commit4796f8dd4bbc5d06daa529ed57feb39fc3708521 (patch)
tree8966ac92884b6f7de09d736343cbeb09f8d1e198
parentdev-python/hypothesis: Bump to 6.78.3 (diff)
downloadgentoo-4796f8dd.tar.gz
gentoo-4796f8dd.tar.bz2
gentoo-4796f8dd.zip
dev-python/backrefs: Bump to 5.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/backrefs/Manifest1
-rw-r--r--dev-python/backrefs/backrefs-5.5.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/backrefs/Manifest b/dev-python/backrefs/Manifest
index 509227cd54f7..76240d75b98c 100644
--- a/dev-python/backrefs/Manifest
+++ b/dev-python/backrefs/Manifest
@@ -1 +1,2 @@
DIST backrefs-5.4.gh.tar.gz 4292341 BLAKE2B 9cbc443b82d2c7339dda30c6790f99d2da38a7e8db78df19e2dc2670c5cc12b1c303870fc63aad16f326b0dfd5d3d1e7c1a85bcde6cb698cd3602488b7e58ef3 SHA512 2949c40bfa60b37eccfd380eb05e5a7f425cad243d6bb332e6f329a1b9747760ca530d4af69daa25441bc9b0d2bd6291699aebf36bd52d055d4e84959ab45100
+DIST backrefs-5.5.gh.tar.gz 5401839 BLAKE2B e8674de4b1f9a068bf7439e56fd14de8afed0635b0f6fe3c99c64b678890939186c7aa2d660bee73d51e01cc982186bddeaf2e4bea5754c1a234992d518f8004 SHA512 00074d30a96da6bd0aedcd3cec02f533a264514832d91ff466a50937fae28566fe95db7fbedc7ffd185300b9529adf7f89bd4366e09f2bd864fa4f0f13963475
diff --git a/dev-python/backrefs/backrefs-5.5.ebuild b/dev-python/backrefs/backrefs-5.5.ebuild
new file mode 100644
index 000000000000..ce61ff14c7c9
--- /dev/null
+++ b/dev-python/backrefs/backrefs-5.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Wrapper around re or regex that adds additional back references"
+HOMEPAGE="
+ https://github.com/facelessuser/backrefs/
+ https://pypi.org/project/backrefs/
+"
+SRC_URI="
+ https://github.com/facelessuser/backrefs/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/regex[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )
+"
+
+distutils_enable_tests pytest