summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2024-03-18 00:15:09 +0200
committerMart Raudsepp <leio@gentoo.org>2024-04-01 22:53:29 +0300
commit479d53111a9b29950d30d3ffa2cdb938a98610e0 (patch)
tree4d0fa8e9731303e736ee70148a637605143b2c5b
parentgstreamer-meson.eclass: Avoid needlessly compiling helper libraries in split ... (diff)
downloadgentoo-479d53111a9b29950d30d3ffa2cdb938a98610e0.tar.gz
gentoo-479d53111a9b29950d30d3ffa2cdb938a98610e0.tar.bz2
gentoo-479d53111a9b29950d30d3ffa2cdb938a98610e0.zip
gstreamer-meson.eclass: Avoid gl getting automatically enabled for base splits
This necessitates adding `gl` to GST_PLUGINS_NOAUTO in gst-plugins-base, or it gets disabled there as well due to eclass additions being appended to the ebuild ones. This is mainly for correctness, as the few base split builds didn't actually end up building anything about GL extra due to this. Signed-off-by: Mart Raudsepp <leio@gentoo.org>
-rw-r--r--eclass/gstreamer-meson.eclass5
-rw-r--r--media-libs/gst-plugins-base/gst-plugins-base-1.20.5.ebuild4
-rw-r--r--media-libs/gst-plugins-base/gst-plugins-base-1.20.6.ebuild4
-rw-r--r--media-libs/gst-plugins-base/gst-plugins-base-1.22.10.ebuild2
4 files changed, 10 insertions, 5 deletions
diff --git a/eclass/gstreamer-meson.eclass b/eclass/gstreamer-meson.eclass
index b9b9b9fa95df..d7af45d81962 100644
--- a/eclass/gstreamer-meson.eclass
+++ b/eclass/gstreamer-meson.eclass
@@ -95,6 +95,11 @@ hls"
soup"
fi
+ if grep -q "option('gl'" "${EMESON_SOURCE}"/meson_options.txt ; then
+ GST_PLUGINS_EXT_DEPS="${GST_PLUGINS_EXT_DEPS}
+gl"
+ fi
+
# See bug #907483
if grep -q "option('qt5'" "${EMESON_SOURCE}"/meson_options.txt ; then
GST_PLUGINS_EXT_DEPS="${GST_PLUGINS_EXT_DEPS}
diff --git a/media-libs/gst-plugins-base/gst-plugins-base-1.20.5.ebuild b/media-libs/gst-plugins-base/gst-plugins-base-1.20.5.ebuild
index 06eb02f51230..ccd2f56aaff7 100644
--- a/media-libs/gst-plugins-base/gst-plugins-base-1.20.5.ebuild
+++ b/media-libs/gst-plugins-base/gst-plugins-base-1.20.5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -101,7 +101,7 @@ multilib_src_configure() {
filter-flags -mno-sse -mno-sse2 -mno-sse4.1 #610340
# opus: split to media-plugins/gst-plugins-opus
- GST_PLUGINS_NOAUTO="alsa ogg pango theora vorbis x11 xshm xvideo"
+ GST_PLUGINS_NOAUTO="alsa gl ogg pango theora vorbis x11 xshm xvideo"
local emesonargs=(
-Dtools=enabled
diff --git a/media-libs/gst-plugins-base/gst-plugins-base-1.20.6.ebuild b/media-libs/gst-plugins-base/gst-plugins-base-1.20.6.ebuild
index 58291e89e8b9..af7541608960 100644
--- a/media-libs/gst-plugins-base/gst-plugins-base-1.20.6.ebuild
+++ b/media-libs/gst-plugins-base/gst-plugins-base-1.20.6.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -101,7 +101,7 @@ multilib_src_configure() {
filter-flags -mno-sse -mno-sse2 -mno-sse4.1 #610340
# opus: split to media-plugins/gst-plugins-opus
- GST_PLUGINS_NOAUTO="alsa ogg pango theora vorbis x11 xshm xvideo"
+ GST_PLUGINS_NOAUTO="alsa gl ogg pango theora vorbis x11 xshm xvideo"
local emesonargs=(
-Dtools=enabled
diff --git a/media-libs/gst-plugins-base/gst-plugins-base-1.22.10.ebuild b/media-libs/gst-plugins-base/gst-plugins-base-1.22.10.ebuild
index 4751eac0eba4..5f0f4b97035e 100644
--- a/media-libs/gst-plugins-base/gst-plugins-base-1.22.10.ebuild
+++ b/media-libs/gst-plugins-base/gst-plugins-base-1.22.10.ebuild
@@ -98,7 +98,7 @@ multilib_src_configure() {
filter-flags -mno-sse -mno-sse2 -mno-sse4.1 #610340
# opus: split to media-plugins/gst-plugins-opus
- GST_PLUGINS_NOAUTO="alsa ogg pango theora vorbis x11 xshm xvideo"
+ GST_PLUGINS_NOAUTO="alsa gl ogg pango theora vorbis x11 xshm xvideo"
local emesonargs=(
-Dtools=enabled