summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-10-28 21:04:38 +0100
committerSam James <sam@gentoo.org>2022-10-28 21:09:25 +0100
commit47b3fca080245e2dea56a3ef42fd5799538e3c6b (patch)
tree78aba4e48c7e4c140fbf2492ab745190408ffbdb
parentmedia-video/pipewire: drop 0.3.51-r2 (diff)
downloadgentoo-47b3fca080245e2dea56a3ef42fd5799538e3c6b.tar.gz
gentoo-47b3fca080245e2dea56a3ef42fd5799538e3c6b.tar.bz2
gentoo-47b3fca080245e2dea56a3ef42fd5799538e3c6b.zip
net-dialup/rp-pppoe: drop 3.15
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-dialup/rp-pppoe/Manifest1
-rw-r--r--net-dialup/rp-pppoe/rp-pppoe-3.15.ebuild100
2 files changed, 0 insertions, 101 deletions
diff --git a/net-dialup/rp-pppoe/Manifest b/net-dialup/rp-pppoe/Manifest
index b5d0fa70c57e..ba927df37a83 100644
--- a/net-dialup/rp-pppoe/Manifest
+++ b/net-dialup/rp-pppoe/Manifest
@@ -1,3 +1,2 @@
-DIST ppp-2.4.9.tar.gz 719904 BLAKE2B 7ba3eb8c98fec5599635dbd302399617e1075f3a1df090f1a94ce2bb8a5c7631e6eea82246adc33711aba5fe95e7ba7c982e2cbf1fb0d71e45f877d9b092ffb7 SHA512 c309f8f69f534c05547cd2f66dade0e0f198ea4c2928a7e899e660280786b3e965437a67b8c5bb81c59d0fa1818b4eb7b701d2dce015a420d380422d2bca4e1a
DIST rp-pppoe-3.14-patches-01.tar.xz 4708 BLAKE2B d0c294490f5c4c8f3f81fccb8234d5eec2257350a41206bf05882aa7e2aa0e2cb0944a962d77e23451f604376168298d5ef99c70b134989c35261bae6046b882 SHA512 0ae0f91e8b9cfcd7d1a1af6cb55f7972e9bc029cd4b10469d5be696ae750d6aabb5f59426e9bf6f700d5a56decd3ddf85a097bb98ae1d06f0b167967b5b8b8ea
DIST rp-pppoe-3.15.tar.gz 224966 BLAKE2B 85eda606677b71e35ed3b9389db0d01ac1f16c7b40cc31b3adf31946b18454b77867a5e8822386e9fb08455399733242c4c074c2fee6f1c4d62fe23b44e82707 SHA512 a156c084e57361ab6a464c3205ffb85cf86d02f71f17f92c9567f1ab0ed300f10030832fd232084699dc842ac4891efc8c54c8165587bfc7b4c92724318a60d9
diff --git a/net-dialup/rp-pppoe/rp-pppoe-3.15.ebuild b/net-dialup/rp-pppoe/rp-pppoe-3.15.ebuild
deleted file mode 100644
index 7ea2da5bedd7..000000000000
--- a/net-dialup/rp-pppoe/rp-pppoe-3.15.ebuild
+++ /dev/null
@@ -1,100 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools readme.gentoo-r1 toolchain-funcs
-
-PPP_P="ppp-2.4.9"
-PATCHES="${PN}-3.14-patches-01"
-
-DESCRIPTION="A user-mode PPPoE client and server suite for Linux"
-HOMEPAGE="https://dianne.skoll.ca/projects/rp-pppoe/"
-SRC_URI="https://dianne.skoll.ca/projects/rp-pppoe/download/${P}.tar.gz
- https://github.com/paulusmack/ppp/archive/${PPP_P}.tar.gz
- https://dev.gentoo.org/~polynomial-c/dist/${PATCHES}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 sparc x86"
-IUSE="tk"
-
-RDEPEND="
- net-dialup/ppp:=
- sys-apps/iproute2
- tk? ( dev-lang/tk:= )
-"
-DEPEND=">=sys-kernel/linux-headers-2.6.25
- elibc_musl? ( net-libs/ppp-defs )
- ${RDEPEND}"
-
-DOC_CONTENTS="Use pppoe-setup to configure your dialup connection"
-
-pkg_setup() {
- # This is needed in multiple phases
- PPPD_VER="$(best_version net-dialup/ppp)"
- PPPD_VER="${PPPD_VER#*/*-}" #reduce it to ${PV}-${PR}
- PPPD_VER="${PPPD_VER%%-*}" #reduce it to ${PV}
-}
-
-src_prepare() {
- if ! use elibc_musl ; then
- rm "${WORKDIR}/patches/${PN}-3.14-musl.patch" || die
- fi
-
- rm "${WORKDIR}/patches/${PN}-3.14-ifconfig-path.patch" || die
-
- eapply "${WORKDIR}/patches"
- eapply_user
-
- cd "${S}"/src || die
- eautoreconf
-}
-
-src_configure() {
- addpredict /dev/ppp
-
- cd src || die
- # Not a mistake! This comes from the GitHub tarball doing funky naming
- econf --enable-plugin=../../ppp-ppp-${PPPD_VER}
-}
-
-src_compile() {
- cd src || die
- emake AR="$(tc-getAR)"
-
- if use tk ; then
- emake -C "${S}/gui"
- fi
-}
-
-src_install() {
- cd src || die
- emake DESTDIR="${D}" install
-
- #Don't use compiled rp-pppoe plugin - see pkg_preinst below
- local pppoe_plugin="${ED}/etc/ppp/plugins/rp-pppoe.so"
- if [[ -f "${pppoe_plugin}" ]] ; then
- rm "${pppoe_plugin}" || die
- fi
-
- if use tk ; then
- emake -C "${S}/gui" \
- DESTDIR="${D}" \
- datadir=/usr/share/doc/${PF}/ \
- install
- dosym doc/${PF}/tkpppoe /usr/share/tkpppoe
- fi
-
- newinitd "${FILESDIR}"/pppoe-server.initd pppoe-server
- newconfd "${FILESDIR}"/pppoe-server.confd pppoe-server
-
- readme.gentoo_create_doc
-}
-
-pkg_preinst() {
- # Use the rp-pppoe plugin that comes with net-dialup/pppd
- if [[ -n "${PPPD_VER}" ]] && [[ -f "${EROOT}/usr/$(get_libdir)/pppd/${PPPD_VER}/rp-pppoe.so" ]] ; then
- dosym ../../../usr/$(get_libdir)/pppd/${PPPD_VER}/rp-pppoe.so /etc/ppp/plugins/rp-pppoe.so
- fi
-}