summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-01-03 20:35:30 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2024-01-03 20:46:40 +0200
commit47c7f3c043623724d75faa16bfcc2e58779dfd88 (patch)
treea5237928a9c97f8c0467dd9f8eec90d99f589155
parentmedia-fonts/noto-emoji: Stabilize 20231130 ppc64, #921278 (diff)
downloadgentoo-47c7f3c043623724d75faa16bfcc2e58779dfd88.tar.gz
gentoo-47c7f3c043623724d75faa16bfcc2e58779dfd88.tar.bz2
gentoo-47c7f3c043623724d75faa16bfcc2e58779dfd88.zip
dev-python/jupyter-core: add 5.7.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/jupyter-core/Manifest1
-rw-r--r--dev-python/jupyter-core/jupyter-core-5.7.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/jupyter-core/Manifest b/dev-python/jupyter-core/Manifest
index a856f5aa0844..94d4a3d6d0da 100644
--- a/dev-python/jupyter-core/Manifest
+++ b/dev-python/jupyter-core/Manifest
@@ -2,3 +2,4 @@ DIST jupyter_core-5.5.0.tar.gz 85369 BLAKE2B 41fa2381023c8f2313607d2ac989d1f35dc
DIST jupyter_core-5.5.1.tar.gz 85962 BLAKE2B a00e96b417d86cc66ac483d031919483ded2e06da9688ed3554d96b5b6709f6ffd1d3602a63160d37c4774d37ee166aed3f3fb81f7f9882482302c8189a19fce SHA512 f82ce8a0f6671b06b6bb768d1a7cf85a9b28be57ba88809334d2fbcfed0d6e2bc5a2320a128ed8a8b498a763d157b1ecc1dc093de1c1aa97a65770a5b715c202
DIST jupyter_core-5.6.0.tar.gz 86418 BLAKE2B 70ab01fc13772f772c374a9452f36926f43bf85c6a19108592ce91238df137116f683692a69cbbb2693a87222728b76de0d4b80563bcd5b6d9019aac874e1d91 SHA512 2a2ff1a6ecc12adbd98b1beaea6206f58fe6d24b841102a436ed42106639992454eb4af2515ff268e95749fa01c3352ac1c919bfb053f3ebe22e1d9d9f9e03d3
DIST jupyter_core-5.6.1.tar.gz 86268 BLAKE2B ad9c04813367ae649002dfea236276e98665dab0dc6484939024eba94e4e687defffebb39f95d2ee8f9a2784388a88996f7dee8cbe93331984ac0e5528243d86 SHA512 ba774e0265a0917d64abb2261dac6ea1e9c6cb2d48f0b988367e3f62b5365481f43141a2904535ba5521246f7409f8eee356418e7cb10deb74859125dfcba0f9
+DIST jupyter_core-5.7.0.tar.gz 87053 BLAKE2B f84eb30745ddf552e0575ee46519c2734d148f61d026c2e0529827342ca29cdeebe7e5866bf9a0c77b3309236f60c2e2303bd6fbc45ebdd6eef696a81d239f84 SHA512 550587edbb31a4c90f60efffa9236b27a3d4b315056f64f4fe79b4396a9c40c769d6263b3bb01d58d92148db8fc24347f3136c59c4b7ffad8c9fa305623cb387
diff --git a/dev-python/jupyter-core/jupyter-core-5.7.0.ebuild b/dev-python/jupyter-core/jupyter-core-5.7.0.ebuild
new file mode 100644
index 000000000000..0f5aa60a25ca
--- /dev/null
+++ b/dev-python/jupyter-core/jupyter-core-5.7.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Core common functionality of Jupyter projects"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter/jupyter_core/
+ https://pypi.org/project/jupyter-core/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ >=dev-python/platformdirs-2.5[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-5.11.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/ipython-4.0.1[${PYTHON_USEDEP}]
+ dev-python/pip[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs \
+ dev-python/myst-parser \
+ dev-python/pydata-sphinx-theme \
+ dev-python/sphinx-autodoc-typehints \
+ dev-python/sphinxcontrib-github-alt \
+ dev-python/sphinxcontrib-spelling \
+ dev-python/traitlets
+distutils_enable_tests pytest