summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2017-10-21 09:35:16 +0100
committerJustin Lecher <jlec@gentoo.org>2017-10-21 09:41:56 +0100
commit47d9c615fd8f300d8c2c2b1576a2a268e4c6bdc7 (patch)
tree06134a96c59e888ce1c77530064cb98841431da6
parentsys-kernel/aufs-sources: Bump to latest genpatches, aufs and linux release (diff)
downloadgentoo-47d9c615fd8f300d8c2c2b1576a2a268e4c6bdc7.tar.gz
gentoo-47d9c615fd8f300d8c2c2b1576a2a268e4c6bdc7.tar.bz2
gentoo-47d9c615fd8f300d8c2c2b1576a2a268e4c6bdc7.zip
sys-cluster/singularity: Version Bump
Closes: https://bugs.gentoo.org/631504 Package-Manager: Portage-2.3.10, Repoman-2.3.3 Signed-off-by: Justin Lecher <jlec@gentoo.org>
-rw-r--r--sys-cluster/singularity/Manifest1
-rw-r--r--sys-cluster/singularity/singularity-2.4.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/sys-cluster/singularity/Manifest b/sys-cluster/singularity/Manifest
index a5f4dc4fadc9..9778f42b461b 100644
--- a/sys-cluster/singularity/Manifest
+++ b/sys-cluster/singularity/Manifest
@@ -1,2 +1,3 @@
DIST singularity-2.2.1.tar.gz 493368 SHA256 0e2a0b0cf6c8d4dc041365f715b2df157e0d8d89986e4eb111c61716df031c8a SHA512 b1195e98254957cd8d80b35b13d4f11060c5836f05ed450d242544fc30f8c298b837ba8986b1184288bc9a5ff2ebb5b1f56dc55a0686b540242b0042a152f902 WHIRLPOOL 3d3c5cb0928bd5beb683c4075c88453d076795c0e41ad30676f7169ccbd6d71a70ad64104833925913138f47b8fc318e90366af79259a05bad41bb0a42703b05
DIST singularity-2.3.1.tar.gz 643021 SHA256 dcccae9ff67a550d142c94e932c0fb59442dd59ae69ce1deeb7ba45829ef2cd7 SHA512 36c581e8dba57d133013c2fcfea26886b54a1a9a9165b011d2cebacb2a6249fe0f8e5aa91ed90f7a18855c658300682436c431a226629408f31422cc8a036600 WHIRLPOOL d9bb8604ce2afb6bb2b5b257eb88276a93987916cd4c08ecc800d98761f5d1ae54e48ed615d77b1c992bcc8bb6202e9bf5e04637d10d1126fba6d1c2619cb98c
+DIST singularity-2.4.tar.gz 689760 SHA256 34ca94250f15354819587364b21b0fdf7eebcff05110f8443caae8ed6961d7da SHA512 b445e73d9794f344ab72ce17d8f802390d0c0c153791b837f416254eadabf19365f1abd29f0b498be5486b600f32cd7fe53e5dc131eee3465ab890c9d6b171f4 WHIRLPOOL 5434f8da66b3863a0c45d17dbe716231b4f04587907ecd608f92d5becb2e34ae599cfebce2a6768a0745fc00ca70297ba7ca9e7370e7080139c8e3eca2b5428d
diff --git a/sys-cluster/singularity/singularity-2.4.ebuild b/sys-cluster/singularity/singularity-2.4.ebuild
new file mode 100644
index 000000000000..904c3ca6693e
--- /dev/null
+++ b/sys-cluster/singularity/singularity-2.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+
+inherit autotools eutils python-single-r1
+
+DESCRIPTION="Application containers for Linux"
+HOMEPAGE="http://singularity.lbl.gov/"
+SRC_URI="https://github.com/${PN}ware/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="cctbx-2.0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples static-libs +suid"
+
+src_prepare() {
+ default
+ # automake version hardcoding
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-userns \
+ $(usex suid "" "--disable-suid") \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ MAKEOPTS+=" -j1"
+ default
+ prune_libtool_files
+ dodoc ChangeLog CONTRIBUTORS.md CONTRIBUTING.md
+ use examples && dodoc -r examples
+}