summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-08-21 12:53:19 +0800
committerIan Delaney <idella4@gentoo.org>2015-08-21 12:53:19 +0800
commit47e087ac7ed4508c2bf262cf9cc1cbe485836192 (patch)
tree2027e7d6e971e388e7d10f3168673af8b0d5262e
parentdev-python/traceback2: add missed keyword x86 (diff)
downloadgentoo-47e087ac7ed4508c2bf262cf9cc1cbe485836192.tar.gz
gentoo-47e087ac7ed4508c2bf262cf9cc1cbe485836192.tar.bz2
gentoo-47e087ac7ed4508c2bf262cf9cc1cbe485836192.zip
dev-python/rsa: bump;
add undocumented dep traceback2, drop pypy3 since new dep fails to support it Package-Manager: portage-2.2.20
-rw-r--r--dev-python/rsa/Manifest1
-rw-r--r--dev-python/rsa/rsa-3.2.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/rsa/Manifest b/dev-python/rsa/Manifest
index 124f0b9ae6a7..19391804adc2 100644
--- a/dev-python/rsa/Manifest
+++ b/dev-python/rsa/Manifest
@@ -1 +1,2 @@
DIST rsa-3.1.4.tar.gz 36181 SHA256 e2b0b05936c276b1edd2e1525553233b666df9e29b5c3ba223eed738277c82a0 SHA512 b6ff7b91909b58359bda5da99ca4297337da5985c5430d2e96663c8bcf599b2180d54afa3316d4c3b11a8f79ddcb1f41d6942a0c8db2f0d27221c3aee132f3c1 WHIRLPOOL bc71d736cb72d222243055ac336ed3d42fde680ad0bc8261802926adfc3c9d8f1321351fbd951c495da843cc6c16bde9dbd27cb235a870dc8817ebfd35c55c7b
+DIST rsa-3.2.tar.gz 33686 SHA256 30f371fbb060747aa53e02c2d53067d8a4f776a7f8ba0e9f0e6bd3f392489777 SHA512 cef1f42534d010e1bbaf62838779a54d20dbbee2b190afec662089c47959c490e279150de7c23bf10a0b53c4e7d4478680df1107a911ea42468b3483274aaf50 WHIRLPOOL 99608189a17f829615bee05f309375a0712f9f438161f37642fe09ad9286aea02475ed723e6f36c55c2cb6139bffd32660b169784ba932dd23433e72ea9e3feb
diff --git a/dev-python/rsa/rsa-3.2.ebuild b/dev-python/rsa/rsa-3.2.ebuild
new file mode 100644
index 000000000000..9d4a9e4da542
--- /dev/null
+++ b/dev-python/rsa/rsa-3.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure-Python RSA implementation"
+HOMEPAGE="http://stuvel.eu/rsa http://pypi.python.org/pypi/rsa"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/pyasn1-0.1.3[${PYTHON_USEDEP}]
+ dev-python/traceback2[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ >=dev-python/setuptools-0.6.10[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/unittest2[${PYTHON_USEDEP}]
+ )
+ "
+
+python_test() {
+ nosetests || die
+}