summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-13 06:44:32 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-13 06:46:30 +0200
commit47ffa816ab5ed7596e5e2a35a539f04900e8c936 (patch)
treee118c59ad142dc5de9cd2f35bfeee69e7b7ae214
parentdev-python/jsonschema-spec: Bump to 0.2.1 (diff)
downloadgentoo-47ffa816ab5ed7596e5e2a35a539f04900e8c936.tar.gz
gentoo-47ffa816ab5ed7596e5e2a35a539f04900e8c936.tar.bz2
gentoo-47ffa816ab5ed7596e5e2a35a539f04900e8c936.zip
dev-python/pylint-venv: Bump to 3.0.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pylint-venv/Manifest1
-rw-r--r--dev-python/pylint-venv/pylint-venv-3.0.2.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/pylint-venv/Manifest b/dev-python/pylint-venv/Manifest
index 4bb8c9e48d01..414eab787300 100644
--- a/dev-python/pylint-venv/Manifest
+++ b/dev-python/pylint-venv/Manifest
@@ -1 +1,2 @@
DIST pylint-venv-3.0.1.gh.tar.gz 14901 BLAKE2B e41a0782fe1bdf83b0019c035cb80416838b71924a1574189aa8936a22fce689523984a277305beba49559d0bcdbde9c8b4ac6a9cb12e1a3853a9a3f287a7a57 SHA512 7b6e7be85dd5552c99d620550e602eb908fccb1ef0982e1734276e14f882261ad7c13309ac796e657865544484a275016981e9b75ef31d17d4c01454b7e091a8
+DIST pylint-venv-3.0.2.gh.tar.gz 15046 BLAKE2B 3c07e00739541c4b9b7c28c9b6cf91e8dee27885adcac8ec88b347f6c580ee0a0c905271eb5b5256ccf0ea975604bf98560ce271a27cbfd2d5790d1143ba6af4 SHA512 716491ffbb5e6642cd61cee62c720a594d85b4cf44feb2d53d3e120dbdea813234776a95341ac10acbdd64354cc3875659f1d3bbc5f45a87ac5232e1e7f89473
diff --git a/dev-python/pylint-venv/pylint-venv-3.0.2.ebuild b/dev-python/pylint-venv/pylint-venv-3.0.2.ebuild
new file mode 100644
index 000000000000..02d3f783d513
--- /dev/null
+++ b/dev-python/pylint-venv/pylint-venv-3.0.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Init-hook to use the same Pylint with different virtual environments"
+HOMEPAGE="
+ https://pypi.org/project/pylint-venv/
+ https://github.com/jgosmann/pylint-venv/
+"
+SRC_URI="
+ https://github.com/jgosmann/pylint-venv/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/pylint-2.14.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/pylint-2.14.0[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ # we need to set PYTHONPATH explicitly since the test runs installed
+ # pylint (i.e. starts outside the test venv)
+ local -x PYTHONPATH=${S}:${PYTHONPATH}
+ bash test/test.sh || die "Test failed with ${EPYTHON}"
+}