summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-08 17:55:19 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-08 17:55:19 +0100
commit480a245aceb7eae9917251fad112744c1a641166 (patch)
tree820a7d2606602ed5806f0df993699152fa3d0345
parentdev-python/cython: Remove old (diff)
downloadgentoo-480a245a.tar.gz
gentoo-480a245a.tar.bz2
gentoo-480a245a.zip
dev-python/pylint: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pylint/Manifest1
-rw-r--r--dev-python/pylint/pylint-2.11.1.ebuild58
2 files changed, 0 insertions, 59 deletions
diff --git a/dev-python/pylint/Manifest b/dev-python/pylint/Manifest
index c03bb75cfcbe..ee99635a75bf 100644
--- a/dev-python/pylint/Manifest
+++ b/dev-python/pylint/Manifest
@@ -1,2 +1 @@
-DIST pylint-2.11.1.gh.tar.gz 967223 BLAKE2B 435bb4589fa6dbfadfa234f8cb968a1d5c39efaf9b37fd20dfadc6feb1e997b34124386dab777b1aa1657bd9a36055d535e231181c71834517528cbbc04c698f SHA512 fe283b6eb8090414ea99809158b4e7f9fe85187ef6488ec37c5f34430793b0b4ff8afd9c97452fe0bb88efb9be001c0fd9f9a09a23081cb79084ae409b277f34
DIST pylint-2.12.2.gh.tar.gz 1032702 BLAKE2B de7dce04159b332baa5c23f4034ee249e49f9239c5c9190213a51a84a47ac2129f8a2265e1ad9c01ab448ec58f4f36653c6de5b0be6bfdf6aa286c8887313759 SHA512 0d2b9b785371af0a1c809271153abbab58f50455b34f12370461ded2c4f3d62656e4c0391adff48e179b95da945a2f44e762863e2b7d63808976bf5f684e20d2
diff --git a/dev-python/pylint/pylint-2.11.1.ebuild b/dev-python/pylint/pylint-2.11.1.ebuild
deleted file mode 100644
index 5d8bf6a9f5e8..000000000000
--- a/dev-python/pylint/pylint-2.11.1.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Python code static checker"
-HOMEPAGE="https://www.logilab.org/project/pylint
- https://pypi.org/project/pylint/
- https://github.com/pycqa/pylint/"
-SRC_URI="
- https://github.com/pycqa/pylint/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ppc ppc64 ~riscv ~s390 sparc x86"
-IUSE="examples"
-
-RDEPEND="
- <dev-python/astroid-2.9[${PYTHON_USEDEP}]
- >=dev-python/astroid-2.8.0[${PYTHON_USEDEP}]
- >=dev-python/isort-4.2.5[${PYTHON_USEDEP}]
- <dev-python/isort-6[${PYTHON_USEDEP}]
- >=dev-python/mccabe-0.6[${PYTHON_USEDEP}]
- <dev-python/mccabe-0.7[${PYTHON_USEDEP}]
- >=dev-python/platformdirs-2.2.0[${PYTHON_USEDEP}]
- >=dev-python/toml-0.7.1[${PYTHON_USEDEP}]
-"
-
-PATCHES=(
- "${FILESDIR}/${PN}-2.4.4-sphinx-theme.patch"
-)
-
-distutils_enable_sphinx doc --no-autodoc
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=(
- # No need to run the benchmarks
- tests/benchmark/test_baseline_benchmarks.py
- )
- # Specify the test directory explicitly to avoid import file mismatches
- epytest tests
-}
-
-python_install_all() {
- if use examples ; then
- docompress -x "/usr/share/doc/${PF}/examples"
- docinto examples
- dodoc -r examples/.
- fi
-
- distutils-r1_python_install_all
-}