summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2022-04-11 14:27:49 -0400
committerBrian Evans <grknight@gentoo.org>2022-04-11 14:27:49 -0400
commit482f36d2e8dff0c6452d6862c6b09a7c7f4ca58e (patch)
tree3e92add22e66f4a9d84037bde656d384b91571f1
parentdev-util/umockdev: Version bump to 0.17.9 (diff)
downloadgentoo-482f36d2e8dff0c6452d6862c6b09a7c7f4ca58e.tar.gz
gentoo-482f36d2e8dff0c6452d6862c6b09a7c7f4ca58e.tar.bz2
gentoo-482f36d2e8dff0c6452d6862c6b09a7c7f4ca58e.zip
dev-php/pecl-zmq: Add new snapshot; Update live targets
Signed-off-by: Brian Evans <grknight@gentoo.org>
-rw-r--r--dev-php/pecl-zmq/Manifest1
-rw-r--r--dev-php/pecl-zmq/pecl-zmq-1.1.3_p20211103.ebuild32
-rw-r--r--dev-php/pecl-zmq/pecl-zmq-9999.ebuild6
3 files changed, 36 insertions, 3 deletions
diff --git a/dev-php/pecl-zmq/Manifest b/dev-php/pecl-zmq/Manifest
index da2d71c9c60d..bbe7c0f90654 100644
--- a/dev-php/pecl-zmq/Manifest
+++ b/dev-php/pecl-zmq/Manifest
@@ -1 +1,2 @@
+DIST pecl-zmq-1.1.3_p20211103.tar.gz 104608 BLAKE2B 5217c77353cf36eb10fbb4825a77e16293770b58ee92aeec3487816c713982c67e1964e3da40b152952abe7a1e2be1dab3e67f53798849bfa1a52f3c47f2884e SHA512 762ecc78fda2e94d7bec57dc329741e0a4a6442e76a8a0bb367576b961e96482f43698e36adc7c8e6a585c914e696e6a17056a1ea680caa96f69faefc604d873
DIST zmq-1.1.3.tgz 82397 BLAKE2B 5c221abf614bcc33c4c69e64308508d544f790371549c421fe2fcdedd67f2e843b2b82d96f517ea9413ffedd128838725e9afc18f0d4048b270d4982571874d0 SHA512 0f03016e315a6c6a1e1d6eca1e20564834d2a924cef06af1b38693933f1e5a094c37e9c432705a64f61d95e82655f61358fc7783e7a6f06c7dd9ad84fc6f7bbc
diff --git a/dev-php/pecl-zmq/pecl-zmq-1.1.3_p20211103.ebuild b/dev-php/pecl-zmq/pecl-zmq-1.1.3_p20211103.ebuild
new file mode 100644
index 000000000000..3263a4973133
--- /dev/null
+++ b/dev-php/pecl-zmq/pecl-zmq-1.1.3_p20211103.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+USE_PHP="php7-4 php8-0 php8-1"
+inherit php-ext-pecl-r3
+
+if [[ ${PV} == "9999" ]]; then
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/mkoppanen/php-zmq.git"
+ EGIT_CHECKOUT_DIR="${PHP_EXT_S}"
+
+ inherit git-r3
+else
+ KEYWORDS="~amd64 ~x86"
+fi
+
+SNAPSHOT="ee5fbc693f07b2d6f0d9fd748f131be82310f386"
+SRC_URI="https://github.com/zeromq/php-zmq/archive/${SNAPSHOT}.tar.gz -> ${P}.tar.gz"
+
+DESCRIPTION="PHP Bindings for ZeroMQ messaging"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+BDEPEND="virtual/pkgconfig"
+DEPEND="net-libs/zeromq"
+RDEPEND="net-libs/zeromq:="
+
+S="${WORKDIR}/php-zmq-${SNAPSHOT}"
+PHP_EXT_S="${S}"
diff --git a/dev-php/pecl-zmq/pecl-zmq-9999.ebuild b/dev-php/pecl-zmq/pecl-zmq-9999.ebuild
index a0147e05ff53..d5bd392cbce7 100644
--- a/dev-php/pecl-zmq/pecl-zmq-9999.ebuild
+++ b/dev-php/pecl-zmq/pecl-zmq-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="7"
+EAPI="8"
-USE_PHP="php7-3 php7-4 php8-0"
+USE_PHP="php7-4 php8-0 php8-1"
inherit php-ext-pecl-r3
if [[ ${PV} == "9999" ]]; then