summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-22 07:04:03 +0100
committerMichał Górny <mgorny@gentoo.org>2022-03-22 07:35:50 +0100
commit4846f5dbfaf91d2f3da373ebc02e3f3c952b5392 (patch)
tree2e1333986a329116de809a88010e9939b7fc20c4
parentdev-libs/libretls: Bump to 3.5.1 (diff)
downloadgentoo-4846f5dbfaf91d2f3da373ebc02e3f3c952b5392.tar.gz
gentoo-4846f5dbfaf91d2f3da373ebc02e3f3c952b5392.tar.bz2
gentoo-4846f5dbfaf91d2f3da373ebc02e3f3c952b5392.zip
dev-python/cfn-lint: Bump to 0.58.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/cfn-lint/Manifest1
-rw-r--r--dev-python/cfn-lint/cfn-lint-0.58.4.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/cfn-lint/Manifest b/dev-python/cfn-lint/Manifest
index 2f22980ec92c..7b103ad6bb25 100644
--- a/dev-python/cfn-lint/Manifest
+++ b/dev-python/cfn-lint/Manifest
@@ -1 +1,2 @@
DIST cfn-lint-0.58.3.tar.gz 8779688 BLAKE2B 0964d477f61ec3dc4f80d59e3b05bc92cba27c0c9293a343bf15ee25df967643adf4d8aaa0c11d336a857957bc19dd1cc711b7fe9014c9c43ffd0171b197c4f5 SHA512 9f88f533a6533cf23ce9be83f61cc7418df7775e331ea932f469b391e136a370e5adef9a41a5378dc99d4aec352ababebc1eb59b15d19c0c0c6f19e12410ae06
+DIST cfn-lint-0.58.4.tar.gz 8838063 BLAKE2B 77caf931c79b90d44c09c7ad63ff928c5217fa3cb9474ce8d3a3151a4a804365293e4304484ae1a2c55acfb2718dddce9f0b26165d35a570c3a7baab3cf76290 SHA512 53c24e265eaa8064bc23740376668c4a640571e0e273fc475f70de468be51683f3eacbbce82dddb9e05a23049299b49e660f28d5ef93150a60260fa0f4b77a19
diff --git a/dev-python/cfn-lint/cfn-lint-0.58.4.ebuild b/dev-python/cfn-lint/cfn-lint-0.58.4.ebuild
new file mode 100644
index 000000000000..b8ea9d7827e1
--- /dev/null
+++ b/dev-python/cfn-lint/cfn-lint-0.58.4.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="CloudFormation Linter"
+HOMEPAGE="https://pypi.org/project/cfn-lint/ https://github.com/aws-cloudformation/cfn-lint/"
+SRC_URI="
+ https://github.com/aws-cloudformation/cfn-lint/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/aws-sam-translator-1.42.0[${PYTHON_USEDEP}]
+ dev-python/jsonpatch[${PYTHON_USEDEP}]
+ >=dev-python/jschema_to_python-1.2.3[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.0[${PYTHON_USEDEP}]
+ dev-python/junit-xml[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ >dev-python/pyyaml-5.4[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.15.0[${PYTHON_USEDEP}]
+ >=dev-python/sarif_om-1.0.4[${PYTHON_USEDEP}]
+ >=dev-python/six-1.11[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # TODO
+ test/unit/module/test_template.py::TestTemplate::test_build_graph
+ # requires git repo
+ test/unit/module/maintenance/test_update_documentation.py::TestUpdateDocumentation::test_update_docs
+ # Internet
+ test/unit/module/formatters/test_formatters.py::TestFormatters::test_sarif_formatter
+ test/unit/module/maintenance/test_update_resource_specs.py::TestUpdateResourceSpecs::test_update_resource_specs_python_2
+ test/unit/module/maintenance/test_update_resource_specs.py::TestUpdateResourceSpecs::test_update_resource_specs_python_3
+)
+
+src_prepare() {
+ # unpin the deps
+ sed -e 's:~=[0-9.]*::' -i setup.py || die
+ distutils-r1_src_prepare
+}