summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-06-20 11:02:37 +1200
committerKent Fredric <kentnl@gentoo.org>2020-06-20 11:03:08 +1200
commit486221eae1556463be820cd34b0eb259788cff53 (patch)
treed5035dd0381030e654176b0c22e61e2aec00320d
parentnet-wireless/iw: fix ebuild header (diff)
downloadgentoo-486221eae1556463be820cd34b0eb259788cff53.tar.gz
gentoo-486221eae1556463be820cd34b0eb259788cff53.tar.bz2
gentoo-486221eae1556463be820cd34b0eb259788cff53.zip
dev-perl/Class-Spiffy: -r bump for EAPI7
- EAPI7 - Remove unused/empty variable assignments - Parallel tests - Migrate to an actual "patch" instead of "sed" - Improve dependencies Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
-rw-r--r--dev-perl/Class-Spiffy/Class-Spiffy-0.150.0-r2.ebuild23
-rw-r--r--dev-perl/Class-Spiffy/files/Class-Spiffy-0.15-no-dot-inc.patch21
-rw-r--r--dev-perl/Class-Spiffy/metadata.xml1
3 files changed, 44 insertions, 1 deletions
diff --git a/dev-perl/Class-Spiffy/Class-Spiffy-0.150.0-r2.ebuild b/dev-perl/Class-Spiffy/Class-Spiffy-0.150.0-r2.ebuild
new file mode 100644
index 000000000000..901907ed1eac
--- /dev/null
+++ b/dev-perl/Class-Spiffy/Class-Spiffy-0.150.0-r2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=INGY
+DIST_VERSION=0.15
+inherit perl-module
+
+DESCRIPTION="Spiffy Perl Interface Framework For You"
+
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ virtual/perl-Scalar-List-Utils
+"
+BDEPEND="
+ ${RDEPEND}
+"
+PATCHES=(
+ "${FILESDIR}/${PN}-0.15-no-dot-inc.patch"
+)
diff --git a/dev-perl/Class-Spiffy/files/Class-Spiffy-0.15-no-dot-inc.patch b/dev-perl/Class-Spiffy/files/Class-Spiffy-0.15-no-dot-inc.patch
new file mode 100644
index 000000000000..f94168fc24a7
--- /dev/null
+++ b/dev-perl/Class-Spiffy/files/Class-Spiffy-0.15-no-dot-inc.patch
@@ -0,0 +1,21 @@
+From 1c979a0223112986d4eb75578dc8c8eb24296c0f Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Sat, 20 Jun 2020 10:51:32 +1200
+Subject: Include '.' in @INC on perl 5.26+
+
+---
+ Makefile.PL | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/Makefile.PL b/Makefile.PL
+index a9195f4..db2bff9 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -1,3 +1,4 @@
++use lib '.';
+ use inc::Module::Install;
+
+ name 'Class-Spiffy';
+--
+2.27.0
+
diff --git a/dev-perl/Class-Spiffy/metadata.xml b/dev-perl/Class-Spiffy/metadata.xml
index 327a43cdad08..5028c2227201 100644
--- a/dev-perl/Class-Spiffy/metadata.xml
+++ b/dev-perl/Class-Spiffy/metadata.xml
@@ -9,6 +9,5 @@
<remote-id type="cpan">Class-Spiffy</remote-id>
<remote-id type="cpan-module">Class::Spiffy</remote-id>
<remote-id type="cpan-module">Class::Spiffy::mixin</remote-id>
- <remote-id type="cpan-module">DB</remote-id>
</upstream>
</pkgmetadata>