summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNP-Hardass <NP-Hardass@gentoo.org>2017-09-20 17:48:21 -0400
committerNP-Hardass <NP-Hardass@gentoo.org>2017-09-20 18:20:42 -0400
commit487449d882b95ff9d88657746ee835553e461a27 (patch)
treea31b37455e809dcd36527ff265b09519d2f2aaa3
parentprofiles: arch/amd64/package.use.force: add abi_x86_64 for virtual/wine (diff)
downloadgentoo-487449d8.tar.gz
gentoo-487449d8.tar.bz2
gentoo-487449d8.zip
net-misc/vde: Revbump to 2.3.2-r4, EAPI bump
Acked-By: mjo@gentoo.org Bug: https://bugs.gentoo.org/603382 Package-Manager: Portage-2.3.8, Repoman-2.3.3
-rw-r--r--net-misc/vde/files/vde.conf-r115
-rw-r--r--net-misc/vde/files/vde.init-r142
-rw-r--r--net-misc/vde/vde-2.3.2-r4.ebuild66
3 files changed, 123 insertions, 0 deletions
diff --git a/net-misc/vde/files/vde.conf-r1 b/net-misc/vde/files/vde.conf-r1
new file mode 100644
index 000000000000..856bde8ea2b0
--- /dev/null
+++ b/net-misc/vde/files/vde.conf-r1
@@ -0,0 +1,15 @@
+# load the tun module
+VDE_MODPROBE_TUN="yes"
+
+# virtual tap networking device to be used for vde
+VDE_TAP="tap0"
+
+# The group that will have access to the VDE control socket.
+VDE_GROUP="qemu"
+
+# VDE socket location (default: /run/${RC_SVCNAME}.ctl)
+VDE_SOCKET=""
+
+# Additional options passed to the vde_switch daemon.
+#VDE_OPTS=""
+VDE_OPTS="" \ No newline at end of file
diff --git a/net-misc/vde/files/vde.init-r1 b/net-misc/vde/files/vde.init-r1
new file mode 100644
index 000000000000..b2ad548f372b
--- /dev/null
+++ b/net-misc/vde/files/vde.init-r1
@@ -0,0 +1,42 @@
+#!/sbin/openrc-run
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+command="/usr/bin/vde_switch"
+pidfile="/run/${RC_SVCNAME}.pid"
+
+depend() {
+ after net.${VDE_TAP}
+}
+
+start_pre() {
+ [ "${VDE_MODPROBE_TUN}" = "yes" ] || return 0
+ modprobe tun
+}
+
+# We have to use start() because the shortform uses --pidfile for s-s-d --start
+# which causes s-s-d to check the pid file before it exists
+start() {
+ VDE_SOCKET="${VDE_SOCKET:-/run/${RC_SVCNAME}.ctl}"
+
+ start-stop-daemon --start --exec ${command} -- \
+ --pidfile=${pidfile} \
+ --tap=${VDE_TAP} \
+ --group=${VDE_GROUP} \
+ --mode=660 \
+ --dirmode=770 \
+ --sock=${VDE_SOCKET} \
+ --daemon \
+ ${VDE_OPTS}
+ ewaitfile 10 "${VDE_SOCKET}"
+
+ eend $? "Failed to start ${RC_SVCNAME}"
+}
+
+stop_post() {
+ [ "${VDE_MODPROBE_TUN}" = "yes" ] && modprobe --quiet --remove tun
+
+ # Don't fail to stop the service if the "tun" module in use
+ # and the above "modprobe -r" command fails.
+ return 0
+}
diff --git a/net-misc/vde/vde-2.3.2-r4.ebuild b/net-misc/vde/vde-2.3.2-r4.ebuild
new file mode 100644
index 000000000000..105d24c63bf4
--- /dev/null
+++ b/net-misc/vde/vde-2.3.2-r4.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit ltprune python-single-r1 user
+
+MY_P="${PN}2-${PV}"
+
+DESCRIPTION="Virtual distributed ethernet emulator for emulators like qemu, bochs, and uml"
+SRC_URI="mirror://sourceforge/vde/${MY_P}.tar.bz2"
+HOMEPAGE="http://vde.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="pcap python selinux ssl libressl static-libs"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+COMMON_DEPS="pcap? ( net-libs/libpcap )
+ python? ( ${PYTHON_DEPS} )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )"
+DEPEND="${COMMON_DEPS}"
+RDEPEND="${COMMON_DEPS}
+ selinux? ( sec-policy/selinux-vde )"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ # default group already used in kqemu
+ enewgroup qemu
+
+ python-single-r1_pkg_setup
+}
+
+src_configure() {
+ econf \
+ $(use_enable pcap) \
+ $(use_enable python) \
+ $(use_enable ssl cryptcab) \
+ $(use_enable static-libs static)
+}
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ default
+ prune_libtool_files
+
+ newinitd "${FILESDIR}"/vde.init-r1 vde
+ newconfd "${FILESDIR}"/vde.conf-r1 vde
+}
+
+pkg_postinst() {
+ einfo "To start vde automatically add it to the default runlevel:"
+ einfo "# rc-update add vde default"
+ einfo "You need to setup tap0 in /etc/conf.d/net"
+ einfo "To use it as an user be sure to set a group in /etc/conf.d/vde"
+}