summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-26 09:25:31 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-26 09:34:46 +0100
commit4876a35884012a563f79276325a82c95dad07c21 (patch)
tree594639673be3b000e17d49bb6a2e69f574267145
parentdev-python/rope: Migrate to PEP517 build (diff)
downloadgentoo-4876a358.tar.gz
gentoo-4876a358.tar.bz2
gentoo-4876a358.zip
dev-python/xlrd: EAPI 8, PEP517
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/xlrd/xlrd-2.0.1-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/xlrd/xlrd-2.0.1-r1.ebuild b/dev-python/xlrd/xlrd-2.0.1-r1.ebuild
new file mode 100644
index 000000000000..33f76f0072a9
--- /dev/null
+++ b/dev-python/xlrd/xlrd-2.0.1-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Library to extract data from Microsoft Excel spreadsheets"
+HOMEPAGE="
+ https://www.python-excel.org/
+ https://github.com/python-excel/xlrd/
+"
+SRC_URI="
+ https://github.com/python-excel/xlrd/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
+
+distutils_enable_tests pytest