summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2024-05-19 10:44:35 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2024-05-19 11:16:51 +0200
commit487f2793f13c66b118e556e892a3e9f7a7026231 (patch)
tree6ea5b9e3ac260d03255d3630cb5905a7849e8930
parentapp-admin/logstalgia: Bump to 1.1.4, EAPI 8, fix dependencies (diff)
downloadgentoo-487f2793f13c66b118e556e892a3e9f7a7026231.tar.gz
gentoo-487f2793f13c66b118e556e892a3e9f7a7026231.tar.bz2
gentoo-487f2793f13c66b118e556e892a3e9f7a7026231.zip
net-libs/nghttp2: add 1.62.0
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
-rw-r--r--net-libs/nghttp2/Manifest1
-rw-r--r--net-libs/nghttp2/nghttp2-1.62.0.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/net-libs/nghttp2/Manifest b/net-libs/nghttp2/Manifest
index 8d9f58da8642..7cadc5ab23fd 100644
--- a/net-libs/nghttp2/Manifest
+++ b/net-libs/nghttp2/Manifest
@@ -1 +1,2 @@
DIST nghttp2-1.61.0.tar.xz 1645808 BLAKE2B e78fb94cc9234260447f0d3610e58e22f9eadc2dd8b79eec3c1bb10d5c03ad3a87f83d54e560e5bbdef5d60086c00b465caabca145485ecd636aa35a2cda616f SHA512 01e930d7caf464699505f92b76e2bc8192d168612dc564d2546812c42afea2fb81d552d70e8a5fed35e2bf5deadbec8eda095af94a2484bca41542988afce52a
+DIST nghttp2-1.62.0.tar.xz 1646596 BLAKE2B 156fe3cd401e89cb9416c3281318f955abe86909d249108781f8eaeb0ff3df791f083ae6fc7bfe04350b91ffeaf8d8799d138d9d7cc9f5121a344f69f7473915 SHA512 1674e269dcf1067312056e5ea0e7108a48a177888fbaae5a194bddcc9640babc996d86e74e3160cd0dc4a360f0440441116259f3b44a3ca5fea081cdff7e7c88
diff --git a/net-libs/nghttp2/nghttp2-1.62.0.ebuild b/net-libs/nghttp2/nghttp2-1.62.0.ebuild
new file mode 100644
index 000000000000..52ec575055cf
--- /dev/null
+++ b/net-libs/nghttp2/nghttp2-1.62.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib
+
+DESCRIPTION="HTTP/2 C Library"
+HOMEPAGE="https://nghttp2.org/"
+SRC_URI="https://github.com/nghttp2/nghttp2/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0/1.14" # 1.<SONAME>
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="debug hpack-tools jemalloc static-libs systemd test utils xml"
+
+REQUIRED_USE="test? ( static-libs )"
+RESTRICT="!test? ( test )"
+
+SSL_DEPEND="
+ >=dev-libs/openssl-1.0.2:0=[-bindist(-),${MULTILIB_USEDEP}]
+"
+RDEPEND="
+ hpack-tools? ( >=dev-libs/jansson-2.5:= )
+ jemalloc? ( dev-libs/jemalloc:=[${MULTILIB_USEDEP}] )
+ utils? (
+ ${SSL_DEPEND}
+ >=dev-libs/libev-4.15[${MULTILIB_USEDEP}]
+ >=sys-libs/zlib-1.2.3[${MULTILIB_USEDEP}]
+ net-dns/c-ares:=[${MULTILIB_USEDEP}]
+ )
+ systemd? ( >=sys-apps/systemd-209 )
+ xml? ( >=dev-libs/libxml2-2.7.7:2[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+multilib_src_configure() {
+ #TODO: enable HTTP3
+ #requires quictls/openssl, libngtcp2, libngtcp2_crypto_quictls, libnghttp3
+ local mycmakeargs=(
+ -DENABLE_EXAMPLES=OFF
+ -DENABLE_FAILMALLOC=OFF
+ -DENABLE_HTTP3=OFF
+ -DENABLE_WERROR=OFF
+ -DENABLE_THREADS=ON
+ -DENABLE_DEBUG=$(usex debug)
+ -DENABLE_HPACK_TOOLS=$(multilib_native_usex hpack-tools)
+ $(cmake_use_find_package hpack-tools Jansson)
+ -DWITH_JEMALLOC=$(multilib_native_usex jemalloc)
+ -DBUILD_STATIC_LIBS=$(usex static-libs)
+ -DBUILD_TESTING=$(usex test)
+ $(cmake_use_find_package systemd Systemd)
+ -DENABLE_APP=$(multilib_native_usex utils)
+ -DWITH_LIBXML2=$(multilib_native_usex xml)
+ )
+ cmake_src_configure
+}
+
+multilib_src_test() {
+ eninja check
+}