summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHarri Nieminen <moikkis@gmail.com>2017-02-14 11:39:49 +0200
committerDavid Seifert <soap@gentoo.org>2017-02-14 20:42:16 +0100
commit4894d215b8cad1a4832b52e9b7d43facf87e7786 (patch)
tree0f52d072e4cbdc8e0ee59dd47a86ec50e36844a1
parentx11-misc/bbkeys: EAPI bump 0 -> 6 (diff)
downloadgentoo-4894d215b8cad1a4832b52e9b7d43facf87e7786.tar.gz
gentoo-4894d215b8cad1a4832b52e9b7d43facf87e7786.tar.bz2
gentoo-4894d215b8cad1a4832b52e9b7d43facf87e7786.zip
x11-misc/bbmail: EAPI bump 2 -> 6
Package-Manager: Portage-2.3.3, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/3967
-rw-r--r--x11-misc/bbmail/bbmail-0.9.3-r1.ebuild40
-rw-r--r--x11-misc/bbmail/files/bbmail-0.9.3-shebang.patch8
2 files changed, 48 insertions, 0 deletions
diff --git a/x11-misc/bbmail/bbmail-0.9.3-r1.ebuild b/x11-misc/bbmail/bbmail-0.9.3-r1.ebuild
new file mode 100644
index 000000000000..8f2493767d94
--- /dev/null
+++ b/x11-misc/bbmail/bbmail-0.9.3-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="blackbox mail notification"
+HOMEPAGE="https://sourceforge.net/projects/bbtools"
+SRC_URI="mirror://sourceforge/bbtools/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="
+ dev-lang/perl
+ x11-wm/blackbox
+ x11-libs/libX11
+ x11-libs/libXext"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc4.3.patch
+ "${FILESDIR}"/${P}-gcc4.4.patch
+ "${FILESDIR}"/${P}-shebang.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install () {
+ default
+ dobin scripts/bbmailparsefm.pl
+}
diff --git a/x11-misc/bbmail/files/bbmail-0.9.3-shebang.patch b/x11-misc/bbmail/files/bbmail-0.9.3-shebang.patch
new file mode 100644
index 000000000000..98ceae80e1a3
--- /dev/null
+++ b/x11-misc/bbmail/files/bbmail-0.9.3-shebang.patch
@@ -0,0 +1,8 @@
+--- a/scripts/bbmailparsefm.pl 2002-10-17 21:33:21.000000000 +0300
++++ b/scripts/bbmailparsefm.pl 2017-02-14 19:49:11.371106962 +0200
+@@ -1,4 +1,4 @@
+-#!/usr/bin/perl
++#!/usr/bin/env perl
+ #
+ # Quickie script to parse fetchmail -c output
+ # (IMAP proto) for use with bbmail