summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2015-09-22 08:37:12 -0500
committerWilliam Hubbs <williamh@gentoo.org>2015-09-22 08:37:12 -0500
commit489d634baa56a0591402da3709e930c1730ed478 (patch)
tree49652a87b0088f460bb557d4b877f269aec28948
parentsys-auth/consolekit: add ~alpha keyword (diff)
downloadgentoo-489d634baa56a0591402da3709e930c1730ed478.tar.gz
gentoo-489d634baa56a0591402da3709e930c1730ed478.tar.bz2
gentoo-489d634baa56a0591402da3709e930c1730ed478.zip
dev-lang/go: Add rdepend to block older go-tools
In go-1.5, vet and cover were moved back from go-tools to the main Go repository. Because of this, we need to make sure we have a correct version of go-tools installed when upgrading. This is for bug #560054.
-rw-r--r--dev-lang/go/go-1.5.1.ebuild2
1 files changed, 1 insertions, 1 deletions
diff --git a/dev-lang/go/go-1.5.1.ebuild b/dev-lang/go/go-1.5.1.ebuild
index 6fc180ca12dc..b34ebb3aaf85 100644
--- a/dev-lang/go/go-1.5.1.ebuild
+++ b/dev-lang/go/go-1.5.1.ebuild
@@ -27,7 +27,7 @@ SLOT="0/${PV}"
IUSE=""
DEPEND=">=dev-lang/go-bootstrap-1.4.1"
-RDEPEND=""
+RDEPEND="!<dev-go/go-tools-0_pre20150902"
# These test data objects have writable/executable stacks.
QA_EXECSTACK="usr/lib/go/src/debug/elf/testdata/*.obj"