summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-09-26 12:53:31 +0200
committerMichał Górny <mgorny@gentoo.org>2022-09-26 13:10:05 +0200
commit48af05f91744265fcafd51b805e9dca1a478af64 (patch)
tree30f96837bdc118907cd34bfdb629c444a9da0571
parentdev-python/stack_data: Bump to 0.5.1 (diff)
downloadgentoo-48af05f91744265fcafd51b805e9dca1a478af64.tar.gz
gentoo-48af05f91744265fcafd51b805e9dca1a478af64.tar.bz2
gentoo-48af05f91744265fcafd51b805e9dca1a478af64.zip
dev-python/executing: Bump to 1.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/executing/Manifest1
-rw-r--r--dev-python/executing/executing-1.1.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/executing/Manifest b/dev-python/executing/Manifest
index e19305e0f696..46624c250e00 100644
--- a/dev-python/executing/Manifest
+++ b/dev-python/executing/Manifest
@@ -1,2 +1,3 @@
DIST executing-0.10.0.gh.tar.gz 507523 BLAKE2B 5ab17adb1d40b83b0cf294aba350faf124a810b4c95e408e9bd2ba80d918154cb41d8b4d4748cd7d897d47e085883a30f431dedd595b00506beb5038e084f473 SHA512 f1ee25679cd1f88f273ee68e8e926a6e98b749a50d063ea3aa73f35ac0d7ea65b13364269f01265f164dba1d775a742cd7cf3594558e06efb39fb1157b3b9f5c
DIST executing-1.0.0.gh.tar.gz 507720 BLAKE2B 601ddbd4c7dacd6b72317e9f07d8b8566d14b1c805bb7a2768449d51bf75818945f3b61b67dd0402d1d6171bd74165107ef98e835910529d82b8858bd016ac6d SHA512 912cea61ddb2ef12034432d68fa7239daad3c6365dbcbed72f08121b9fdc07e614b5c2233c53f5f7ee3472fca4f690af3db0944a0ed2c83623de8d682cff0a61
+DIST executing-1.1.0.gh.tar.gz 782214 BLAKE2B 56c97b1c0b6617db90a90f562409b406d0838e187fed4e45642506df85ae5e54824a393eb38982902bdb1c67fda2299bac282a5b260f3537cd06145b1c5b992e SHA512 090705c90051fdbf53310293fbb2e06bd2c2144cf83d3d02528768303c70871bd8b3a3d236705e29f8a9fc3132ca94bcb3375fe8834529a684b10b7c879faff0
diff --git a/dev-python/executing/executing-1.1.0.ebuild b/dev-python/executing/executing-1.1.0.ebuild
new file mode 100644
index 000000000000..26b7519766f7
--- /dev/null
+++ b/dev-python/executing/executing-1.1.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Get information about what a Python frame is currently doing"
+HOMEPAGE="
+ https://github.com/alexmojaki/executing/
+ https://pypi.org/project/executing/
+"
+SRC_URI="
+ https://github.com/alexmojaki/executing/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+# asttokens is optional runtime dep
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/asttokens[${PYTHON_USEDEP}]
+ dev-python/littleutils[${PYTHON_USEDEP}]
+ dev-python/rich[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_test() {
+ # this test explodes when collected by pytest
+ "${EPYTHON}" tests/test_main.py || die "Tests failed with ${EPYTHON}"
+ epytest tests/test_pytest.py
+}