summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-07-27 18:28:14 +0100
committerMarek Szuba <marecki@gentoo.org>2021-07-27 18:29:16 +0100
commit48b15bf2eb35edbd9b6b328d68c5fa96d905a685 (patch)
treea880388ec72ff1723fd2430bb77af1553b39e485
parentdev-ml/cairo2: bump 0.6.2 (diff)
downloadgentoo-48b15bf2eb35edbd9b6b328d68c5fa96d905a685.tar.gz
gentoo-48b15bf2eb35edbd9b6b328d68c5fa96d905a685.tar.bz2
gentoo-48b15bf2eb35edbd9b6b328d68c5fa96d905a685.zip
app-backup/borgmatic: get rid of vim dependency in tests
Already merged upstream so will no longer be needed come 1.5.17. Signed-off-by: Marek Szuba <marecki@gentoo.org>
-rw-r--r--app-backup/borgmatic/borgmatic-1.5.16.ebuild3
-rw-r--r--app-backup/borgmatic/files/borgmatic-1.5.16-tests_no_vim_dep.patch34
2 files changed, 35 insertions, 2 deletions
diff --git a/app-backup/borgmatic/borgmatic-1.5.16.ebuild b/app-backup/borgmatic/borgmatic-1.5.16.ebuild
index 72cfe91c89cb..faca0182b6c8 100644
--- a/app-backup/borgmatic/borgmatic-1.5.16.ebuild
+++ b/app-backup/borgmatic/borgmatic-1.5.16.ebuild
@@ -25,10 +25,8 @@ RDEPEND="app-backup/borgbackup
dev-python/requests[${PYTHON_USEDEP}]
<dev-python/ruamel-yaml-0.18.0[${PYTHON_USEDEP}]
')"
-# one of the tests needs xxd
BDEPEND="
test? (
- app-editors/vim-core
$(python_gen_cond_dep '
dev-python/flexmock[${PYTHON_USEDEP}]
')
@@ -38,6 +36,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-1.5.1-no_test_coverage.patch
"${FILESDIR}"/${PN}-1.5.16-flexmock_write_args.patch
"${FILESDIR}"/${PN}-1.5.16-systemd_service_bin_path.patch
+ "${FILESDIR}"/${PN}-1.5.16-tests_no_vim_dep.patch # already merged upstream
)
distutils_enable_tests pytest
diff --git a/app-backup/borgmatic/files/borgmatic-1.5.16-tests_no_vim_dep.patch b/app-backup/borgmatic/files/borgmatic-1.5.16-tests_no_vim_dep.patch
new file mode 100644
index 000000000000..492743e36e04
--- /dev/null
+++ b/app-backup/borgmatic/files/borgmatic-1.5.16-tests_no_vim_dep.patch
@@ -0,0 +1,34 @@
+From e8b8d86592565acde1ac6e7809947b8a761f2f91 Mon Sep 17 00:00:00 2001
+From: Marek Szuba <marek.szuba@cern.ch>
+Date: Tue, 27 Jul 2021 13:46:51 +0100
+Subject: [PATCH] tests/integration/test_execute: use plain Python rather than
+ xxd
+
+Removes this test's dependencies on vim and /dev/urandom.
+
+Signed-off-by: Marek Szuba <marek.szuba@cern.ch>
+---
+ tests/integration/test_execute.py | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/tests/integration/test_execute.py b/tests/integration/test_execute.py
+index 6dc6467..3b9bef9 100644
+--- a/tests/integration/test_execute.py
++++ b/tests/integration/test_execute.py
+@@ -1,5 +1,6 @@
+ import logging
+ import subprocess
++import sys
+
+ import pytest
+ from flexmock import flexmock
+@@ -134,7 +135,8 @@ def test_log_outputs_vents_other_processes_when_one_exits():
+ flexmock(module).should_receive('command_for_process').and_return('grep')
+
+ process = subprocess.Popen(
+- ['xxd', '-l', '40000', '-p', '/dev/urandom'], stdout=subprocess.PIPE, stderr=subprocess.PIPE
++ [sys.executable, '-c', "import random, string; print(''.join(random.choice(string.ascii_letters) for _ in range(40000)))"],
++ stdout=subprocess.PIPE, stderr=subprocess.PIPE
+ )
+ other_process = subprocess.Popen(
+ ['true'], stdin=process.stdout, stdout=subprocess.PIPE, stderr=subprocess.STDOUT