summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-07-01 00:14:53 -0400
committerTim Harder <radhermit@gentoo.org>2018-07-01 00:16:16 -0400
commit48b25bbf9da4da72349c4b7885e3a078aa42a2bb (patch)
tree26c6142142a9124d0a7fd553b2a6c5306322b2d3
parentdev-python/llfuse: version bump to 1.3.4 (diff)
downloadgentoo-48b25bbf.tar.gz
gentoo-48b25bbf.tar.bz2
gentoo-48b25bbf.zip
dev-python/pretend: version bump to 1.0.9
-rw-r--r--dev-python/pretend/Manifest1
-rw-r--r--dev-python/pretend/pretend-1.0.9.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/pretend/Manifest b/dev-python/pretend/Manifest
index 236cfd509195..959a085e4e7e 100644
--- a/dev-python/pretend/Manifest
+++ b/dev-python/pretend/Manifest
@@ -1,2 +1,3 @@
DIST pretend-1.0.8.gh.tar.gz 5509 BLAKE2B 574c83f05c9b45876891df97a23a25cefb0f27f9ba76aa6d01fe8d2246f7b4457fb99522540d85108056dd83e79ed7179c4661d30fbc786ce2adf0c477a23560 SHA512 f0a3263f55afc43bfd63a6ba0ae876f2607ed9cc26352a3ec69933ebb79418a128c5c29c3e77a924b158da658d8ff2043a7f8e6d4ee3e499df22e4083329cf62
DIST pretend-1.0.8.tar.gz 4848 BLAKE2B 396fae55208e39eadceaff92890b48d63b79a24e0d313a3b87d69b8a61655cb8a1a2f8823f06779e0730fb3505cb269ca907dd28a79fdd283ebd6913bd9c0ab3 SHA512 25011216947289d340fb979ebc9e2c7f000571f006cf5ce15f10ff0e013164e4329a3a66933d202acf8ced498929cf9e5a2a3666aafa00f78348400615c5cec8
+DIST pretend-1.0.9.tar.gz 5656 BLAKE2B 1a8e280fbbf147f502f1148b9e3685630e0f5cd270dc8b6fa8fbbd8177aaa08efe401a6684b669a976d828e7fcdd48d686170bfa3cd3d8a857b78af473a5b6f8 SHA512 976e3272557aecfb11e4147a868ea96e23546e277d57d726f41b945103bef3451039716e6bbc5082d691fa1fd331c06b3d0f8b254deb0510948153571326eaf0
diff --git a/dev-python/pretend/pretend-1.0.9.ebuild b/dev-python/pretend/pretend-1.0.9.ebuild
new file mode 100644
index 000000000000..3204641875df
--- /dev/null
+++ b/dev-python/pretend/pretend-1.0.9.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A library for stubbing in Python"
+HOMEPAGE="https://github.com/alex/pretend/ https://pypi.org/project/pretend/"
+SRC_URI="https://github.com/alex/pretend/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+python_test() {
+ py.test -v || die
+}