summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-11 23:46:05 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-12 00:08:51 +0200
commit48b5989e621b3ffe762c1912085572a508dec568 (patch)
tree10ad617309e5934b7e86e5aae29f59b77188b525
parentdev-python/keyring: Bump to 23.2.0 (diff)
downloadgentoo-48b5989e.tar.gz
gentoo-48b5989e.tar.bz2
gentoo-48b5989e.zip
dev-python/setuptools_scm: Bump to 6.3.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/setuptools_scm/Manifest1
-rw-r--r--dev-python/setuptools_scm/setuptools_scm-6.3.2.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/setuptools_scm/Manifest b/dev-python/setuptools_scm/Manifest
index 54bc23aa3235..837a70d29701 100644
--- a/dev-python/setuptools_scm/Manifest
+++ b/dev-python/setuptools_scm/Manifest
@@ -1,2 +1,3 @@
DIST setuptools_scm-6.0.1.tar.gz 51433 BLAKE2B 7045eec0c1a43d6c93c94e0b2799f0d000cda509fa0df9ee9a638b95383f07fe430b07c3bf72fdc4809563ac289521976956f728a4b2984921fa31532bb7ed8b SHA512 db27653c57f674ec62689247680adace3779216249f1b09a35e8a0233a1ec1acb9ae89b52acd439f7062da2ba1a45b8c0d6d81333ddda0764447c30698ddb314
DIST setuptools_scm-6.3.0.tar.gz 57117 BLAKE2B c0190e4d8f10f05fb6413d651ca15133cef4474bd460ab3bdda4b81d3410078cf9cf20e40de042bda29fe0b99c409b6d934c3d6a648350688f5b4496eabecefc SHA512 c3751d27345b9423b9fe7eec15fbf6c3e3bc19679b7960a589bdcb729a53b5dba40be27878f87dc0d908fae190ef8db76ee19379e0d6dd5cb00b44950cae3896
+DIST setuptools_scm-6.3.2.tar.gz 57207 BLAKE2B 4291f3810dc5ea111a6bad1bf37c8704a7eb6cdd112ea476d629d6175c43cc7d8f78d450181c0e588a5f3fc0fc092fedb41fcb6e198a42f730f9fc6b8d96e343 SHA512 9a16552803ef92367ad71007cf322737b5baa58b924083f04c860875bf6cb2e2bb4f43a7f89778b040c2eb55c5d32de479a918056519339820c6d0f1a6a386f0
diff --git a/dev-python/setuptools_scm/setuptools_scm-6.3.2.ebuild b/dev-python/setuptools_scm/setuptools_scm-6.3.2.ebuild
new file mode 100644
index 000000000000..11ac1212f1e3
--- /dev/null
+++ b/dev-python/setuptools_scm/setuptools_scm-6.3.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Manage versions by scm tags via setuptools"
+HOMEPAGE="
+ https://github.com/pypa/setuptools_scm/
+ https://pypi.org/project/setuptools-scm/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/tomli[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ !!<dev-python/setuptools_scm-2
+ test? (
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ dev-vcs/git
+ !sparc? ( dev-vcs/mercurial )
+ )"
+
+distutils_enable_tests --install pytest
+
+EPYTEST_DESELECT=(
+ # fetching from the Internet
+ testing/test_regressions.py::test_pip_download
+ testing/test_setuptools_support.py
+)