summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2018-05-23 18:43:42 -0400
committerAaron Bauman <bman@gentoo.org>2018-05-23 18:43:42 -0400
commit48ba7760fa6b26b4413be0125a7c9517f9bce8cb (patch)
treef28ef8e0f3b577669a385536399d21bdca20136c
parentdev-libs/libreport: sys-apps/systemd to COMMON_DEPEND (diff)
downloadgentoo-48ba7760fa6b26b4413be0125a7c9517f9bce8cb.tar.gz
gentoo-48ba7760fa6b26b4413be0125a7c9517f9bce8cb.tar.bz2
gentoo-48ba7760fa6b26b4413be0125a7c9517f9bce8cb.zip
app-admin/abrt: bumpity bump bump
Bug: https://bugs.gentoo.org/546798 Bug: https://bugs.gentoo.org/546912 Closes: https://bugs.gentoo.org/451742 Package-Manager: Portage-2.3.38, Repoman-2.3.9
-rw-r--r--app-admin/abrt/Manifest1
-rw-r--r--app-admin/abrt/abrt-2.10.9.ebuild113
2 files changed, 114 insertions, 0 deletions
diff --git a/app-admin/abrt/Manifest b/app-admin/abrt/Manifest
index 7b74df7388e8..f6dc6cffde51 100644
--- a/app-admin/abrt/Manifest
+++ b/app-admin/abrt/Manifest
@@ -1 +1,2 @@
DIST abrt-2.0.12.tar.gz 1090121 BLAKE2B 272f486bd166a33fea3e340763b3443b5643a650fe16ad326e249309c355f214c67937456dd2d8f3e7cdac65cb85bd8030e6b89671f427085a05dca64b8f874d SHA512 5432205edb4483fb1883b9bcebab48784b16dd9e72c3a929ea0d50c48dab638d80f136b6b0d7648d8ec9fcb79d5ce8c1be37d36301d3b2b151868901be82a63a
+DIST abrt-2.10.9.tar.gz 6830234 BLAKE2B ec96b915103c8b8157eb64c98791d283225091d0f2aa7b78520bfae1bee22f43703715fabc43828c750aa7e84eea4a886878d411670b7b4ad31ca49b96d387f3 SHA512 1ff7e2edf29085fb03c569b67e8bf2bc83aaf4dd77730e5fc96184453224f83dd0632eaf85a7ad03351fdfaea3d4ed50e8a89eb28d82151f95bd34eb1850f93c
diff --git a/app-admin/abrt/abrt-2.10.9.ebuild b/app-admin/abrt/abrt-2.10.9.ebuild
new file mode 100644
index 000000000000..e17cca9bceff
--- /dev/null
+++ b/app-admin/abrt/abrt-2.10.9.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit autotools xdg-utils python-single-r1 systemd user
+
+DESCRIPTION="Automatic bug detection and reporting tool"
+HOMEPAGE="https://github.com/abrt/abrt/wiki/ABRT-Project"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug selinux systemd"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+COMMON_DEPEND="${PYTHON_DEPS}
+ >=dev-libs/glib-2.43:2
+ >=dev-libs/libreport-2.9.5[python]
+ dev-libs/libxml2
+ dev-libs/nss
+ >=gnome-base/gsettings-desktop-schemas-3.15.1
+ sys-apps/dbus
+ sys-auth/polkit
+ sys-fs/inotify-tools
+ x11-libs/gtk+:3
+ >=x11-libs/libnotify-0.7"
+RDEPEND="${COMMON_DEPEND}
+ app-arch/cpio
+ dev-libs/elfutils
+ dev-python/argcomplete
+ dev-python/argh
+ dev-python/humanize
+ sys-apps/util-linux
+ >=sys-devel/gdb-7"
+DEPEND="${COMMON_DEPEND}
+ app-text/asciidoc
+ app-text/xmlto
+ dev-libs/satyr[${PYTHON_USEDEP}]
+ >=dev-util/intltool-0.35.0
+ virtual/pkgconfig
+ >=sys-devel/gettext-0.17"
+
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+RESTRICT="test" # tests *may* be broken due to all the RHEL crap. explore later.
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+
+ enewgroup abrt
+ enewuser abrt -1 -1 -1 abrt
+}
+
+src_prepare() {
+ default
+
+ # pyhook test is sensitive to the format of python's error messages, and
+ # fails with certain python versions
+ sed -e '/pyhook.at/ d' \
+ -i tests/Makefile.* tests/testsuite.at || die "sed remove pyhook tests failed"
+ ./gen-version || die # Needed to be run before autoreconf
+ eautoreconf
+}
+
+src_configure() {
+
+ myeconfargs=(
+ --libdir="${EPREFIX}/$(get_libdir)"
+ --localstatedir="${EPREFIX}/var"
+ --without-bodhi
+ # package breaks due to not finding libreport-web with bodhi plugin enabled
+ --without-rpm
+ $(usex selinux "" "--without-selinux")
+ --without-python2
+ # Fixes "syntax error in VERSION script" and we aren't supporting Python2 anyway
+ $(usex python "--with-python3" "--without-python3")
+ --without-pythondoc
+ # package breaks due to no sphinx-build-3
+ --without-pythontests
+ # kill tests for now until they can be explored.
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ keepdir /var/run/abrt
+ # /var/spool/abrt is created by dev-libs/libreport
+
+ diropts -m 700 -o abrt -g abrt
+ keepdir /var/spool/abrt-upload
+
+ diropts -m 775 -o abrt -g abrt
+ keepdir /var/cache/abrt-di
+
+ find "${D}" -name '*.la' -exec rm -f {} + || die
+
+ newinitd "${FILESDIR}/${PN}-2.0.12-r1-init" abrt
+ newconfd "${FILESDIR}/${PN}-2.0.12-r1-conf" abrt
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}