summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-07-09 12:16:49 +0200
committerMichał Górny <mgorny@gentoo.org>2022-07-09 12:17:10 +0200
commit48ce256d2045a747a0a0edf9702e3171df410b91 (patch)
tree2791cf6fd11741aa3d1236df0f0ecc6cbaaed590
parentnet-mail/mu: drop 1.6.11, 1.7.23, 1.8.1 (diff)
downloadgentoo-48ce256d2045a747a0a0edf9702e3171df410b91.tar.gz
gentoo-48ce256d2045a747a0a0edf9702e3171df410b91.tar.bz2
gentoo-48ce256d2045a747a0a0edf9702e3171df410b91.zip
dev-python/docutils-glep: Bump to 1.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/docutils-glep/Manifest1
-rw-r--r--dev-python/docutils-glep/docutils-glep-1.4.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/docutils-glep/Manifest b/dev-python/docutils-glep/Manifest
index 12f4ae1d538b..41eccb7267bc 100644
--- a/dev-python/docutils-glep/Manifest
+++ b/dev-python/docutils-glep/Manifest
@@ -1,2 +1,3 @@
DIST docutils-glep-1.3.gh.tar.gz 6719 BLAKE2B 55d0ac9632d3f3c65f149f444ccdbb24cb4aaad42766f2ef94c11877e3994301630fe2d3f7f3229ddcdb3950c28f2e095af7d0a6563329f588e732c196e7c430 SHA512 20d0fc1f97144a2566b62e40fae85b750e2c4bab50efee18f102f3d6cf7bffeb0d60a6c7e8feeb231afaeff309c4faea1c105fa26f8f4a6d140b5863abeda980
+DIST docutils-glep-1.4.gh.tar.gz 6758 BLAKE2B 92b519022df5d8ac90b7eae15a08e0f0738badcc7018d8d621f9789ddfa97a0ad3989a39b65068ebd1e5ad90b2ddcbd6c4e953de06562391b12eaefebd60dd7a SHA512 601da0d0f7c4fdb2976755c8ca57e07b55b8d87e99735378a3dd5b1b43099d0fe2bb8317265d23e61b536b907901e75a3b527e16125dfaf2ccb178452e411af3
DIST docutils_glep-1.2.tar.gz 6771 BLAKE2B ecb17f69dd2edb12d81ea1bf90789564e86b921125c20913134500dd53ae04b0962141183cbcb9bd17af904196ead2228e4c80a6e256576b715ae6323afadc30 SHA512 696412447120893c198dcd9f13e042d20b35465e83ef8b488ee2f1c184b5fd3928ddbf10ed4e78886c4c72dfe1f9fa46c1f75c7997990afcc04353b5d59ebf9f
diff --git a/dev-python/docutils-glep/docutils-glep-1.4.ebuild b/dev-python/docutils-glep/docutils-glep-1.4.ebuild
new file mode 100644
index 000000000000..7901094e4045
--- /dev/null
+++ b/dev-python/docutils-glep/docutils-glep-1.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Gentoo GLEP support for docutils"
+HOMEPAGE="
+ https://github.com/mgorny/docutils-glep/
+ https://pypi.org/project/docutils-glep/
+"
+SRC_URI="
+ https://github.com/mgorny/docutils-glep/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="
+ >=dev-python/docutils-0.10[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"