summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-09-01 12:30:35 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-09-01 12:43:35 +0200
commit48ce504c726b6796a20fefac6b1f6d3c1803adbd (patch)
treeddc870de42438d4f32b85cc184ff9bf1efeca8b4
parentsys-libs/libieee1284: new rev bump (diff)
downloadgentoo-48ce504c726b6796a20fefac6b1f6d3c1803adbd.tar.gz
gentoo-48ce504c726b6796a20fefac6b1f6d3c1803adbd.tar.bz2
gentoo-48ce504c726b6796a20fefac6b1f6d3c1803adbd.zip
sys-libs/libieee1284: migrate to EAPI=7
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
-rw-r--r--sys-libs/libieee1284/libieee1284-0.2.11-r7.ebuild22
1 files changed, 13 insertions, 9 deletions
diff --git a/sys-libs/libieee1284/libieee1284-0.2.11-r7.ebuild b/sys-libs/libieee1284/libieee1284-0.2.11-r7.ebuild
index 9cb0704f1c11..6966e3e27a5b 100644
--- a/sys-libs/libieee1284/libieee1284-0.2.11-r7.ebuild
+++ b/sys-libs/libieee1284/libieee1284-0.2.11-r7.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI="7"
PYTHON_COMPAT=( python2_7 )
@@ -17,25 +17,29 @@ KEYWORDS="amd64 ppc x86"
IUSE="doc python static-libs"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-RDEPEND="
- python? ( ${PYTHON_DEPS} )"
-DEPEND="${RDEPEND}
- doc? (
+BDEPEND="doc? (
app-text/docbook-sgml-utils
>=app-text/docbook-sgml-dtd-4.1
app-text/docbook-dsssl-stylesheets
dev-perl/XML-RegExp
)"
+DEPEND="python? ( ${PYTHON_DEPS} )"
+
+RDEPEND="${DEPEND}"
+
pkg_setup() {
use python && python-single-r1_pkg_setup
}
multilib_src_configure() {
- ECONF_SOURCE="${S}" econf \
- --enable-shared \
- $(use_enable static-libs static) \
+ local myeconfargs=(
+ --enable-shared
+ $(use_enable static-libs static)
$(multilib_native_use_with python)
+ )
+
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
}
multilib_src_install_all() {
@@ -43,6 +47,6 @@ multilib_src_install_all() {
dodoc doc/interface*
if ! use static-libs; then
- find "${D}" -name '*.la' -delete || die
+ find "${ED}" -name '*.la' -delete || die
fi
}